summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-11-18 14:50:13 +0100
committerRemi Collet <remi@php.net>2022-11-18 14:50:13 +0100
commit1a90e1b27ddd7cf2caf58b057e1088ef9c8a066b (patch)
tree42a18f44c10a240a24ac696f5283f24806e850d9
parentf64915c560d50df4f8918bd1cf8036d6fd9547c9 (diff)
update to 2.16.0HEADmaster
lower dependency on PHP 8.0
-rw-r--r--composer.json14
-rw-r--r--php-laminas-db.spec44
2 files changed, 29 insertions, 29 deletions
diff --git a/composer.json b/composer.json
index be7db1d..3973d9e 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,7 @@
"config": {
"sort-packages": true,
"platform": {
- "php": "7.3.99"
+ "php": "8.0.99"
},
"allow-plugins": {
"dealerdirect/phpcodesniffer-composer-installer": true
@@ -31,15 +31,15 @@
}
},
"require": {
- "php": "^7.3 || ~8.0.0 || ~8.1.0",
+ "php": "~8.0.0 || ~8.1.0|| ~8.2.0",
"laminas/laminas-stdlib": "^3.7.1"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~2.2.1",
- "laminas/laminas-eventmanager": "^3.4.0",
- "laminas/laminas-hydrator": "^3.2 || ^4.3",
- "laminas/laminas-servicemanager": "^3.7.0",
- "phpunit/phpunit": "^9.5.19"
+ "laminas/laminas-coding-standard": "^2.4.0",
+ "laminas/laminas-eventmanager": "^3.6.0",
+ "laminas/laminas-hydrator": "^4.7",
+ "laminas/laminas-servicemanager": "^3.19.0",
+ "phpunit/phpunit": "^9.5.25"
},
"suggest": {
"laminas/laminas-eventmanager": "Laminas\\EventManager component",
diff --git a/php-laminas-db.spec b/php-laminas-db.spec
index 19d0283..86f325e 100644
--- a/php-laminas-db.spec
+++ b/php-laminas-db.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 1125ef2e55108bdfcc1f0030d3a0f9b895e09606
+%global gh_commit 0fb9d7a32b40036a158961a5df082ff421321aa7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-db
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.15.0
+Version: 2.16.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 8.0
BuildRequires: php-date
BuildRequires: php-pcre
BuildRequires: php-pdo
@@ -44,33 +44,32 @@ BuildRequires: php-spl
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.7.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~2.2.1",
-# "laminas/laminas-eventmanager": "^3.4.0",
-# "laminas/laminas-hydrator": "^3.2 || ^4.3",
-# "laminas/laminas-servicemanager": "^3.7.0",
-# "phpunit/phpunit": "^9.5.19"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.4 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-hydrator) >= 3.2 with php-autoloader(%{gh_owner}/laminas-hydrator) < 5)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.7 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
-BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
+# "laminas/laminas-coding-standard": "~2.4.0",
+# "laminas/laminas-eventmanager": "^3.6.0",
+# "laminas/laminas-hydrator": "^4.7",
+# "laminas/laminas-servicemanager": "^3.19.0",
+# "phpunit/phpunit": "^9.5.25"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.6 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-hydrator) >= 4.7 with php-autoloader(%{gh_owner}/laminas-hydrator) < 5)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.19 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
# remirepo:7
%else
BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-laminas-eventmanager
-BuildRequires: php-laminas-hydrator3
+BuildRequires: php-laminas-hydrator4
BuildRequires: php-laminas-servicemanager
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.18
+BuildRequires: phpunit9 >= 9.5.25
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.0",
+# "php": "php": "~8.0.0 || ~8.1.0|| ~8.2.0",
# "laminas/laminas-stdlib": "^3.6",
-Requires: php(language) >= 7.3
+Requires: php(language) >= 8.0
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -132,12 +131,9 @@ cat << 'EOF' | tee -a src/autoload.php
'%{php_home}/%{namespace}/Stdlib/autoload.php',
]);
\Fedora\Autoloader\Dependencies::optional([
- '%{php_home}/%{namespace}/EventManager/autoload.php',
- [
- '%{php_home}/%{namespace}/Hydrator4/autoload.php',
- '%{php_home}/%{namespace}/Hydrator3/autoload.php',
- ],
'%{php_home}/%{namespace}/ServiceManager/autoload.php',
+ '%{php_home}/%{namespace}/EventManager/autoload.php',
+ '%{php_home}/%{namespace}/Hydrator4/autoload.php',
]);
EOF
@@ -179,7 +175,7 @@ exit (class_exists("\\Zend\\%{library}\\ConfigProvider") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -202,6 +198,10 @@ exit $ret
%changelog
+* Fri Nov 18 2022 Remi Collet <remi@remirepo.net> - 2.16.0-1
+- update to 2.16.0
+- lower dependency on PHP 8.0
+
* Mon Apr 11 2022 Remi Collet <remi@remirepo.net> - 2.15.0-1
- update to 2.15.0