summaryrefslogtreecommitdiffstats
path: root/php-laminas-config3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-config3.spec')
-rw-r--r--php-laminas-config3.spec42
1 files changed, 23 insertions, 19 deletions
diff --git a/php-laminas-config3.spec b/php-laminas-config3.spec
index bfdb8b4..cbf9814 100644
--- a/php-laminas-config3.spec
+++ b/php-laminas-config3.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit b8fe057f55e69a0e7a2e4ced79218a43f58606a8
+%global gh_commit 0bce6f5abab41dc673196741883b19018a2b5994
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-config
@@ -23,7 +23,7 @@
%endif
Name: php-%{gh_project}%{major}
-Version: 3.3.0
+Version: 3.4.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component v%{major}
@@ -32,12 +32,10 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-#Patch0: https://github.com/zendframework/zend-config/commit/27d5ba5c13cb4a576400f534057b69231190ac9d.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-json
BuildRequires: php-libxml
BuildRequires: php-pcre
@@ -46,18 +44,18 @@ BuildRequires: php-xmlreader
BuildRequires: php-xmlwriter
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
-BuildRequires: (php-composer(psr/container) >= 1.0 with php-composer(psr/container) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+BuildRequires: (php-composer(psr/container) >= 1.0 with php-composer(psr/container) < 2)
# From composer, "require-dev": {
# "laminas/laminas-filter": "^2.7.2",
-# "laminas/laminas-i18n": "^2.7.4",
-# "laminas/laminas-servicemanager": "^2.7.8 || ^3.3",
+# "laminas/laminas-i18n": "^2.10.3",
+# "laminas/laminas-servicemanager": "^3.4.1",
# "malukenho/docheader": "^0.1.6",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.7.2 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.7.4 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+# "phpunit/phpunit": "^8.5.8"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.7.2 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.10.3 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.4.1 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
# remirepo:8
%else
BuildRequires: php-laminas-stdlib
@@ -67,20 +65,20 @@ BuildRequires: php-laminas-filter
BuildRequires: php-laminas-i18n
BuildRequires: php-laminas-servicemanager
%endif
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+BuildRequires: phpunit8 >= 8.5.8
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ^8.0",
# "ext-json": "*",
# "laminas/laminas-stdlib": "^2.7.7 || ^3.1",
# "laminas/laminas-zendframework-bridge": "^1.0",
# "psr/container": "^1.0"
# "laminas/laminas-stdlib": "^2.7 || ^3.0",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
Requires: php-json
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -182,9 +180,9 @@ exit (class_exists("\\Zend\\%{library}\\Config") ? 0 : 1);
: upstream test suite
ret=0
-for cmd in php php72 php73 php74; do
+for cmd in php php72 php73 php74 php80; do
if which $cmd; then
- $cmd %{_bindir}/phpunit || ret=1
+ $cmd %{_bindir}/phpunit8 || ret=1
fi
done
exit $ret
@@ -204,6 +202,11 @@ exit $ret
%changelog
+* Tue Aug 25 2020 Remi Collet <remi@remirepo.net> - 3.4.0-1
+- update to 3.4.0
+- raise dependency on PHP 7.3
+- switch to phpunit8
+
* Mon Jan 20 2020 Remi Collet <remi@remirepo.net> - 3.3.0-1
- rename to php-laminas-config3
- install in /usr/share/php/Laminas/Config3
@@ -213,6 +216,7 @@ exit $ret
- add dependency on psr/container
- add dependency on json extention
- drop dependency on laminas-json
+- switch to phpunit7
* Fri Jan 17 2020 Remi Collet <remi@remirepo.net> - 2.6.0-2
- cleanup