From 1f749943c821866f54c5bb3fada70ad130f12920 Mon Sep 17 00:00:00 2001
From: Remi Collet <remi@remirepo.net>
Date: Wed, 13 Jan 2021 10:56:43 +0100
Subject: update laminas-cache-storage-adapter-filesystem to 1.1.0 (no change)

---
 composer-filesystem.json | 96 ++++++++++++++++++++++++------------------------
 makesrc.sh               | 50 -------------------------
 php-laminas-cache.spec   | 11 ++++--
 3 files changed, 54 insertions(+), 103 deletions(-)
 delete mode 100755 makesrc.sh

diff --git a/composer-filesystem.json b/composer-filesystem.json
index 3c74fa3..90e772f 100644
--- a/composer-filesystem.json
+++ b/composer-filesystem.json
@@ -1,52 +1,50 @@
 {
-  "name": "laminas/laminas-cache-storage-adapter-filesystem",
-  "description": "Laminas cache adapter for filesystem",
-  "keywords": [
-    "laminas",
-    "cache"
-  ],
-  "license": "BSD-3-Clause",
-  "require": {
-    "php": "^5.6 || ^7.0"
-  },
-  "conflict": {
-    "laminas/laminas-cache": "<2.10"
-  },
-  "provide": {
-    "laminas/laminas-cache-storage-implementation": "1.0"
-  },
-  "require-dev": {
-    "laminas/laminas-cache": "^2.10",
-    "laminas/laminas-cache-storage-adapter-test": "^1.0@dev",
-    "laminas/laminas-coding-standard": "~1.0.0",
-    "squizlabs/php_codesniffer": "^2.7"
-  },
-  "config": {
-    "sort-packages": true
-  },
-  "extra": {},
-  "autoload": {
-    "psr-4": {
-      "Laminas\\Cache\\Storage\\Adapter\\": "src/"
+    "name": "laminas/laminas-cache-storage-adapter-filesystem",
+    "description": "Laminas cache adapter for filesystem",
+    "keywords": [
+        "laminas",
+        "cache"
+    ],
+    "license": "BSD-3-Clause",
+    "require": {
+        "php": "^7.3 || ~8.0.0",
+        "laminas/laminas-cache": "^2.10@dev"
+    },
+    "provide": {
+        "laminas/laminas-cache-storage-implementation": "1.0"
+    },
+    "require-dev": {
+        "laminas/laminas-cache-storage-adapter-test": "^1.0@dev",
+        "laminas/laminas-coding-standard": "~1.0.0",
+        "squizlabs/php_codesniffer": "^2.7"
+    },
+    "config": {
+        "sort-packages": true
+    },
+    "extra": {
+    },
+    "autoload": {
+        "psr-4": {
+            "Laminas\\Cache\\Storage\\Adapter\\": "src/"
+        }
+    },
+    "autoload-dev": {
+        "psr-4": {
+            "LaminasTest\\Cache\\Storage\\Adapter\\": "test/unit",
+            "LaminasTest\\Cache\\Psr\\": "test/integration/Psr"
+        }
+    },
+    "scripts": {
+        "cs-check": "phpcs",
+        "cs-fix": "phpcbf",
+        "test": "phpunit --colors=always",
+        "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+    },
+    "support": {
+        "issues": "https://github.com/laminas/laminas-cache-storage-adapter-filesystem/issues",
+        "forum": "https://discourse.laminas.dev/",
+        "source": "https://github.com/laminas/laminas-cache-storage-adapter-filesystem",
+        "docs": "https://docs.laminas.dev/laminas-cache-storage-adapter-filesystem/",
+        "rss": "https://github.com/laminas/laminas-cache-storage-adapter-filesystem/releases.atom"
     }
-  },
-  "autoload-dev": {
-    "psr-4": {
-      "LaminasTest\\Cache\\Storage\\Adapter\\": "test/unit",
-      "LaminasTest\\Cache\\Psr\\": "test/integration/Psr"
-    }
-  },
-  "scripts": {
-    "cs-check": "phpcs",
-    "cs-fix": "phpcbf",
-    "test": "phpunit --colors=always",
-    "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
-  },
-  "support": {
-    "issues": "https://github.com/laminas/laminas-cache-storage-adapter-filesystem/issues",
-    "forum": "https://discourse.laminas.dev/",
-    "source": "https://github.com/laminas/laminas-cache-storage-adapter-filesystem",
-    "docs": "https://docs.laminas.dev/laminas-cache-storage-adapter-filesystem/",
-    "rss": "https://github.com/laminas/laminas-cache-storage-adapter-filesystem/releases.atom"
-  }
 }
diff --git a/makesrc.sh b/makesrc.sh
deleted file mode 100755
index 2382ade..0000000
--- a/makesrc.sh
+++ /dev/null
@@ -1,50 +0,0 @@
-#!/bin/bash
-
-function archive() {
-  SHORT=${COMMIT:0:7}
-
-  if [ -f $NAME-$VERSION-$SHORT.tgz ]
-  then
-    echo Skip $NAME
-  else
-    echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION ($COMMIT)\n"
-    echo "Cloning..."
-    rm -rf $PROJECT-$COMMIT
-    git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
-
-    echo "Getting commit..."
-    pushd $PROJECT-$COMMIT
-      if git checkout $COMMIT; then
-        cp composer.json ../${1:-composer.json}
-      else
-        exit 1
-      fi
-    popd
-
-    echo "Archiving..."
-    tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
-
-    echo "Cleaning..."
-    rm -rf $PROJECT-$COMMIT
-  fi
-}
-
-NAME=$(basename $PWD)
-SPEC=$NAME.spec
-OWNER=$(sed   -n '/^%global gh_owner/{s/.* //;p}'   $SPEC)
-PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $SPEC)
-VERSION=$(sed -n '/^Version:/{s/.* //;p}'           $SPEC)
-COMMIT=$(sed  -n '/^%global gh_commit/{s/.* //;p}'  $SPEC)
-archive
-
-for i in test apc apcu blackhole dba ext-mongodb filesystem memcache memcached memory mongodb redis session wincache xcache zend-server
-do
-  j=${i/-/_}
-  NAME=php-laminas-cache-storage-adapter-$i
-  COMMIT=$(sed  -n "/^%global gh_${j}_commit/{s/.* //;p}"  $SPEC)
-  VERSION=$(sed  -n "/^%global gh_${j}_version/{s/.* //;p}"  $SPEC)
-  PROJECT=laminas-cache-storage-adapter-$i
-  archive composer-$i.json
-done
-
-echo "Done."
diff --git a/php-laminas-cache.spec b/php-laminas-cache.spec
index c3d8adf..05c4e93 100644
--- a/php-laminas-cache.spec
+++ b/php-laminas-cache.spec
@@ -1,6 +1,6 @@
 # remirepo/Fedora spec file for php-laminas-cache
 #
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
 # License: CC-BY-SA
 # http://creativecommons.org/licenses/by-sa/4.0/
 #
@@ -45,8 +45,8 @@
 %global gh_ext_mongodb_version    1.0.1
 %global gh_ext_mongodb_short      %(c=%{gh_ext_mongodb_commit}; echo ${c:0:7})
 # Filesystem adapter
-%global gh_filesystem_commit      ae1723bcd84efbdae8f20cbb1bacb9ce9c13dbde
-%global gh_filesystem_version     1.0.1
+%global gh_filesystem_commit      e803d9942b30396491efbe649a3886450d22385f
+%global gh_filesystem_version     1.1.0
 %global gh_filesystem_short       %(c=%{gh_filesystem_commit}; echo ${c:0:7})
 # Memcache adapter
 %global gh_memcache_commit        62d0fab1cd261b44a81821e986c0110d7dda896b
@@ -88,7 +88,7 @@
 
 Name:           php-%{gh_project}
 Version:        2.10.0
-Release:        1%{?dist}
+Release:        2%{?dist}
 Summary:        %{namespace} Framework %{library} component
 
 License:        BSD
@@ -372,6 +372,9 @@ exit $ret
 
 
 %changelog
+* Wed Jan 13 2021 Remi Collet <remi@remirepo.net> - 2.10.0-2
+- update laminas-cache-storage-adapter-filesystem to 1.1.0 (no change)
+
 * Mon Nov  9 2020 Remi Collet <remi@remirepo.net> - 2.10.0-1
 - update to 2.10.0
 - bundle all cache storage adapters
-- 
cgit