summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer-redis.json12
-rw-r--r--composer-session.json9
-rw-r--r--composer.json14
-rw-r--r--php-laminas-cache.spec71
4 files changed, 62 insertions, 44 deletions
diff --git a/composer-redis.json b/composer-redis.json
index 9b3849e..42716d9 100644
--- a/composer-redis.json
+++ b/composer-redis.json
@@ -7,19 +7,21 @@
],
"license": "BSD-3-Clause",
"require": {
- "php": "^5.6 || ^7.0"
+ "php": "^7.3 || ~8.0.0"
},
"conflict": {
- "laminas/laminas-cache": "<2.10"
+ "laminas/laminas-cache": "<2.10",
+ "phpunit/phpunit": "<6.1.0"
},
"provide": {
"laminas/laminas-cache-storage-implementation": "1.0"
},
"require-dev": {
+ "ext-redis": "*",
"laminas/laminas-cache": "^2.10",
- "laminas/laminas-cache-storage-adapter-test": "^1.0@dev",
- "laminas/laminas-coding-standard": "~1.0.0",
- "squizlabs/php_codesniffer": "^2.7"
+ "laminas/laminas-cache-storage-adapter-test": "^1.1",
+ "laminas/laminas-coding-standard": "^2.1",
+ "laminas/laminas-serializer": "^2.10"
},
"config": {
"sort-packages": true
diff --git a/composer-session.json b/composer-session.json
index d8f80b3..06d0036 100644
--- a/composer-session.json
+++ b/composer-session.json
@@ -7,7 +7,7 @@
],
"license": "BSD-3-Clause",
"require": {
- "php": "^5.6 || ^7.0"
+ "php": "^7.3 || ~8.0.0"
},
"conflict": {
"laminas/laminas-cache": "<2.10"
@@ -17,10 +17,9 @@
},
"require-dev": {
"laminas/laminas-cache": "^2.10",
- "laminas/laminas-cache-storage-adapter-test": "^1.0@dev",
- "laminas/laminas-coding-standard": "~1.0.0",
- "laminas/laminas-session": "^2.7.4",
- "squizlabs/php_codesniffer": "^2.7"
+ "laminas/laminas-cache-storage-adapter-test": "^1.1",
+ "laminas/laminas-coding-standard": "^2.1",
+ "laminas/laminas-session": "^2.7.4"
},
"suggest": {
"laminas/laminas-session": "Laminas\\Session component"
diff --git a/composer.json b/composer.json
index efd87f3..4381b9e 100644
--- a/composer.json
+++ b/composer.json
@@ -28,7 +28,7 @@
}
},
"require": {
- "php": "^5.6 || ^7.0",
+ "php": "^7.3 || ~8.0.0",
"laminas/laminas-cache-storage-adapter-apc": "^1.0",
"laminas/laminas-cache-storage-adapter-apcu": "^1.0",
"laminas/laminas-cache-storage-adapter-blackhole": "^1.0",
@@ -44,19 +44,19 @@
"laminas/laminas-cache-storage-adapter-wincache": "^1.0",
"laminas/laminas-cache-storage-adapter-xcache": "^1.0",
"laminas/laminas-cache-storage-adapter-zend-server": "^1.0",
- "laminas/laminas-eventmanager": "^2.6.3 || ^3.2",
- "laminas/laminas-servicemanager": "^2.7.8 || ^3.3",
- "laminas/laminas-stdlib": "^3.2.1",
+ "laminas/laminas-eventmanager": "^3.3",
+ "laminas/laminas-servicemanager": "^3.6",
+ "laminas/laminas-stdlib": "^3.3",
"laminas/laminas-zendframework-bridge": "^1.0",
"psr/cache": "^1.0",
"psr/simple-cache": "^1.0"
},
"require-dev": {
- "cache/integration-tests": "^0.16",
"laminas/laminas-coding-standard": "~1.0.0",
"laminas/laminas-serializer": "^2.6",
- "phpbench/phpbench": "^0.13",
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
+ "phpbench/phpbench": "^1.0.0-alpha8",
+ "phpspec/prophecy-phpunit": "^2.0",
+ "phpunit/phpunit": "^9.5"
},
"provide": {
"psr/cache-implementation": "1.0",
diff --git a/php-laminas-cache.spec b/php-laminas-cache.spec
index f072112..23d121d 100644
--- a/php-laminas-cache.spec
+++ b/php-laminas-cache.spec
@@ -11,7 +11,7 @@
# When buid without laminas-session
%global bootstrap 0
-%global gh_commit 23d1340f4c044681819a2b4f0379e460d43ce9fb
+%global gh_commit d789161db92a25b065f35f8c915b37d94b496270
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-cache
@@ -65,12 +65,12 @@
%global gh_mongodb_version 1.0.1
%global gh_mongodb_short %(c=%{gh_mongodb_commit}; echo ${c:0:7})
# Redis adapter
-%global gh_redis_commit 3fe904953d17728d7fdaa87be603231f23fb0a4d
-%global gh_redis_version 1.0.1
+%global gh_redis_commit f871faafa8706f662ff10bc6ac63271b463af2ff
+%global gh_redis_version 1.1.0
%global gh_redis_short %(c=%{gh_redis_commit}; echo ${c:0:7})
# Session adapter
-%global gh_session_commit 0d2276cd61bd162cd38c53aaa22f18137621dc0c
-%global gh_session_version 1.0.1
+%global gh_session_commit 74a275056cfca2300eb9a67cd1d917f7066b4113
+%global gh_session_version 1.1.0
%global gh_session_short %(c=%{gh_session_commit}; echo ${c:0:7})
# wincache adapter - Windows only
%global gh_wincache_commit 0f54599c5d9aff11b01adadd2742097f923170ba
@@ -87,7 +87,7 @@
Name: php-%{gh_project}
-Version: 2.10.2
+Version: 2.11.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -117,7 +117,7 @@ Source115: %{name}-storage-adapter-zend-server-%{gh_zend_server_version}-%{
BuildArch: noarch
# Tests
%if %{with tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-reflection
BuildRequires: php-date
BuildRequires: php-dba
@@ -125,25 +125,29 @@ BuildRequires: php-pcre
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.2 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.6 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
BuildRequires: (php-composer(psr/cache) >= 1.0 with php-composer(psr/cache) < 2)
BuildRequires: (php-composer(psr/simple-cache) >= 1.0 with php-composer(psr/simple-cache) < 2)
# From composer, "require-dev": {
-# "cache/integration-tests": "^0.16",
# "laminas/laminas-coding-standard": "~1.0.0",
# "laminas/laminas-serializer": "^2.6",
# "laminas/laminas-session": "^2.7.4",
-# "phpbench/phpbench": "^0.13",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
-BuildRequires: (php-composer(cache/integration-tests) >= 0.16 with php-composer(cache/integration-tests) < 1)
+# "phpbench/phpbench": "^1.0.0-alpha8",
+# "phpspec/prophecy-phpunit": "^2.0",
+# "phpunit/phpunit": "^9.5"
+# From laminas/laminas-cache-storage-adapter-test composer, "require": {
+# "cache/integration-tests": "^0.17",
+# "phpunit/phpunit": "^9.5"
+BuildRequires: (php-composer(cache/integration-tests) >= 0.17 with php-composer(cache/integration-tests) < 1)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-serializer) >= 2.6 with php-autoloader(%{gh_owner}/laminas-serializer) < 3)
+BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
%if ! %{bootstrap}
BuildRequires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.7.4 with php-autoloader(%{gh_owner}/laminas-session) < 3)
%endif
-# remirepo:13
+# remirepo:14
%else
BuildRequires: php-laminas-eventmanager
BuildRequires: php-laminas-servicemanager
@@ -153,30 +157,31 @@ BuildRequires: php-psr-cache
BuildRequires: php-psr-simple-cache
BuildRequires: php-cache-integration-tests
BuildRequires: php-laminas-serializer
+BuildRequires: php-phpspec-prophecy-phpunit
%if ! %{bootstrap}
BuildRequires: php-laminas-session
%endif
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.2
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.5
# Autoloader
BuildRequires: php-fedora-autoloader-devel
%endif
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
-# "laminas/laminas-eventmanager": "^2.6.3 || ^3.2",
-# "laminas/laminas-servicemanager": "^2.7.8 || ^3.3",
-# "laminas/laminas-stdlib": "^3.2.1",
+# "php": "^7.3 || ~8.0.0",
+# "laminas/laminas-eventmanager": "^3.3",
+# "laminas/laminas-servicemanager": "^3.6",
+# "laminas/laminas-stdlib": "^3.3",
# "laminas/laminas-zendframework-bridge": "^1.0",
# "psr/cache": "^1.0",
# "psr/simple-cache": "^1.0"
Requires: php(language) >= 5.6
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.2 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.6 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
Requires: (php-composer(psr/cache) >= 1.0 with php-composer(psr/cache) < 2)
Requires: (php-composer(psr/simple-cache) >= 1.0 with php-composer(psr/simple-cache) < 2)
@@ -268,6 +273,9 @@ do
ext-mongodb|memcache|memcached|mongodb|redis)
# skip test requiring a running server
;;
+ blackhole|dba|zend-server)
+ # skip test no ready for PHPUnit 9
+ ;;
%if %{bootstrap}
session)
;;
@@ -330,6 +338,7 @@ cat << 'EOF' | tee vendor/autoload.php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Dependencies::required([
'%{php_home}/Cache/IntegrationTests/autoload.php',
+ '%{php_home}/Prophecy/PhpUnit/autoload.php',
]);
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
@@ -344,8 +353,6 @@ find test/ -type f \
-exec sed \
-e 's/function setUp()$/function setUp(): void/' \
-e 's/function tearDown()$/function tearDown(): void/' \
- -e 's/>onlyMethods(/>setMethods(/' \
- -e 's/>assertMatchesRegularExpression(/>assertRegExp(/' \
-i {} \;
: upstream test suite
@@ -354,7 +361,7 @@ ret=0
for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} || ret=1
fi
done
@@ -381,6 +388,16 @@ exit $ret
%changelog
+* Mon May 3 2021 Remi Collet <remi@remirepo.net> - 2.11.0-1
+- update to 2.11.0
+- update laminas-cache-storage-adapter-redis to 1.1.0
+- update laminas-cache-storage-adapter-session to 1.1.0
+- raise dependency on PHP 7.3
+- raise dependency on laminas-eventmanager 3.3
+- raise dependency on laminas-servicemanager 3.6
+- raise dependency on laminas-stdlib 3.3
+- switch to phpunit9
+
* Thu Apr 29 2021 Remi Collet <remi@remirepo.net> - 2.10.2-1
- update to 2.10.2
- update laminas-cache-storage-adapter-filesystem to 1.1.1