summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer-apcu.json7
-rw-r--r--composer.json2
-rw-r--r--php-laminas-cache.spec14
3 files changed, 14 insertions, 9 deletions
diff --git a/composer-apcu.json b/composer-apcu.json
index c2565b4..bab5704 100644
--- a/composer-apcu.json
+++ b/composer-apcu.json
@@ -7,7 +7,7 @@
],
"license": "BSD-3-Clause",
"require": {
- "php": "^5.6 || ^7.0"
+ "php": "^7.3 || ~8.0.0"
},
"conflict": {
"laminas/laminas-cache": "<2.10"
@@ -16,8 +16,9 @@
"laminas/laminas-cache-storage-implementation": "1.0"
},
"require-dev": {
- "laminas/laminas-cache": "^2.10",
- "laminas/laminas-cache-storage-adapter-test": "^1.0@dev",
+ "ext-apcu": "*",
+ "laminas/laminas-cache": "^2.10.1",
+ "laminas/laminas-cache-storage-adapter-test": "^1.1.1",
"laminas/laminas-coding-standard": "~1.0.0",
"squizlabs/php_codesniffer": "^2.7"
},
diff --git a/composer.json b/composer.json
index 4381b9e..9fc07d2 100644
--- a/composer.json
+++ b/composer.json
@@ -54,7 +54,7 @@
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
"laminas/laminas-serializer": "^2.6",
- "phpbench/phpbench": "^1.0.0-alpha8",
+ "phpbench/phpbench": "^1.0.0-beta2",
"phpspec/prophecy-phpunit": "^2.0",
"phpunit/phpunit": "^9.5"
},
diff --git a/php-laminas-cache.spec b/php-laminas-cache.spec
index ad06263..bfcd895 100644
--- a/php-laminas-cache.spec
+++ b/php-laminas-cache.spec
@@ -11,7 +11,7 @@
# When buid without laminas-session
%global bootstrap 0
-%global gh_commit d789161db92a25b065f35f8c915b37d94b496270
+%global gh_commit f888588c3a40916e505658c9e8b8922166b70ec6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-cache
@@ -29,8 +29,8 @@
%global gh_apc_version 1.0.1
%global gh_apc_short %(c=%{gh_apc_commit}; echo ${c:0:7})
# APCu adapter
-%global gh_apcu_commit 1fdd7585042c1a577f6e630535df1e86e23cf5dc
-%global gh_apcu_version 1.0.1
+%global gh_apcu_commit e182aab739d6b03992a9915cc3c7019391a94548
+%global gh_apcu_version 1.1.0
%global gh_apcu_short %(c=%{gh_apcu_commit}; echo ${c:0:7})
# Blackhole adapter
%global gh_blackhole_commit 4af1053efd81785a292c2a9442871c075700345a
@@ -87,8 +87,8 @@
Name: php-%{gh_project}
-Version: 2.11.0
-Release: 2%{?dist}
+Version: 2.11.1
+Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
License: BSD
@@ -388,6 +388,10 @@ exit $ret
%changelog
+* Tue May 4 2021 Remi Collet <remi@remirepo.net> - 2.11.1-1
+- update to 2.11.1
+- update laminas-cache-storage-adapter-apcu to 1.1.0
+
* Mon May 3 2021 Remi Collet <remi@remirepo.net> - 2.11.0-2
- update laminas-cache-storage-adapter-blackhole to 1.2.1
- update laminas-cache-storage-adapter-memcache to 1.1.0