summaryrefslogtreecommitdiffstats
path: root/php-laminas-authentication.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-authentication.spec')
-rw-r--r--php-laminas-authentication.spec52
1 files changed, 28 insertions, 24 deletions
diff --git a/php-laminas-authentication.spec b/php-laminas-authentication.spec
index 02277ba..7f272f5 100644
--- a/php-laminas-authentication.spec
+++ b/php-laminas-authentication.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit ecb59c6d7f7d0ed39790264ca16a94636cac98ae
+%global gh_commit 12bfb36b8b20052a5fee2ae69b0f12064ce16fa9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-authentication
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.12.0
+Version: 2.13.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.4
+BuildRequires: php(language) >= 8.0
BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-hash
@@ -47,24 +47,24 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.12 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~2.4.0",
-# "laminas/laminas-crypt": "^2.6.0 || ^3.2.1",
-# "laminas/laminas-db": "^2.13.0",
-# "laminas/laminas-http": "^2.15",
-# "laminas/laminas-ldap": "^2.12.0",
-# "laminas/laminas-session": "^2.12.0",
-# "laminas/laminas-uri": "^2.9.1",
-# "laminas/laminas-validator": "^2.15.0",
-# "phpunit/phpunit": "^9.3.4",
-# "psalm/plugin-phpunit": "^0.15.1",
+# "laminas/laminas-crypt": "^2.6.0 || ^3.9.0",
+# "laminas/laminas-db": "^2.15.0",
+# "laminas/laminas-http": "^2.17.0",
+# "laminas/laminas-ldap": "^2.15.0",
+# "laminas/laminas-session": "^2.13.0",
+# "laminas/laminas-uri": "^2.10.0",
+# "laminas/laminas-validator": "^2.26.0",
+# "phpunit/phpunit": "^9.5.25",
+# "psalm/plugin-phpunit": "^0.17.0",
# "squizlabs/php_codesniffer": "^3.6.0",
-# "vimeo/psalm": "^4.6.0"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-crypt) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-crypt) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.13 with php-autoloader(%{gh_owner}/laminas-db) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.15 with php-autoloader(%{gh_owner}/laminas-http) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-ldap) >= 2.12 with php-autoloader(%{gh_owner}/laminas-ldap) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.12 with php-autoloader(%{gh_owner}/laminas-session) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.9.1 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.15.0 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
+# "vimeo/psalm": "^4.29.0"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-crypt) >= 3.9 with php-autoloader(%{gh_owner}/laminas-crypt) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.15 with php-autoloader(%{gh_owner}/laminas-db) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.17 with php-autoloader(%{gh_owner}/laminas-http) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-ldap) >= 2.15 with php-autoloader(%{gh_owner}/laminas-ldap) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.13 with php-autoloader(%{gh_owner}/laminas-session) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.10 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.26 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
# remirepo:12
%else
BuildRequires: php-laminas-stdlib
@@ -79,15 +79,15 @@ BuildRequires: php-laminas-validator
BuildRequires: php-laminas-servicemanager
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.3
+BuildRequires: phpunit9 >= 9.5.25
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.4 || ~8.0.0 || ~8.1.0",
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
# "laminas/laminas-stdlib": "^3.6.0"
-Requires: php(language) >= 7.4
+Requires: php(language) >= 8.0
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -206,7 +206,7 @@ exit (class_exists("\\Zend\\%{library}\\Result") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -230,6 +230,10 @@ exit $ret
%changelog
+* Mon Oct 24 2022 Remi Collet <remi@remirepo.net> - 2.13.0-1
+- update to 2.13.0
+- raise dependency on PHP 8.0
+
* Tue Sep 20 2022 Remi Collet <remi@remirepo.net> - 2.12.0-1
- update to 2.12.0
- raise dependency on PHP 7.4