summaryrefslogtreecommitdiffstats
path: root/php-khanamiryan-qrcode-detector-decoder.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-khanamiryan-qrcode-detector-decoder.spec')
-rw-r--r--php-khanamiryan-qrcode-detector-decoder.spec62
1 files changed, 42 insertions, 20 deletions
diff --git a/php-khanamiryan-qrcode-detector-decoder.spec b/php-khanamiryan-qrcode-detector-decoder.spec
index 00e7e42..229decb 100644
--- a/php-khanamiryan-qrcode-detector-decoder.spec
+++ b/php-khanamiryan-qrcode-detector-decoder.spec
@@ -1,12 +1,14 @@
# remirepo/fedora spec file for php-khanamiryan-qrcode-detector-decoder
#
-# Copyright (c) 2017-2019 Remi Collet
+# Copyright (c) 2017-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit a75482d3bc804e3f6702332bfda6cccbb0dfaa76
+%bcond_without tests
+
+%global gh_commit 45326fb83a2a375065dbb3a134b5b8a5872da569
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner khanamiryan
%global gh_project php-qrcode-detector-decoder
@@ -17,24 +19,19 @@
%global ns_vendor %nil
%global ns_project Zxing
%global php_home %{_datadir}/php
-%global with_tests 0%{!?_without_tests:1}
Name: php-%{pk_vendor}-%{pk_project}
-Version: 1.0.2
-Release: 3%{?dist}
+Version: 1.0.6
+Release: 1%{?dist}
Summary: QR code decoder / reader
Group: Development/Libraries
-# https://github.com/khanamiryan/php-qrcode-detector-decoder/issues/29
License: MIT and ASL 2.0
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
-# From https://github.com/khanamiryan/php-qrcode-detector-decoder/pull/80
-Patch0: https://patch-diff.githubusercontent.com/raw/khanamiryan/php-qrcode-detector-decoder/pull/80.patch
-
BuildArch: noarch
-%if %{with_tests}
+%if %{with tests}
# For tests
BuildRequires: php(language) >= 5.6
BuildRequires: php-reflection
@@ -44,14 +41,14 @@ BuildRequires: php-iconv
BuildRequires: php-mbstring
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^5.7"
-BuildRequires: php-composer(phpunit/phpunit)
-# Required by autoloader
+# "phpunit/phpunit": "^9.0"
+%global phpunit %{_bindir}/phpunit9
%endif
+# Required by autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": "^5.6|^7.0"
+# "php": ">=5.6"
Requires: php(language) >= 5.6
# From phpcompatinfo report for version 1
Requires: php-reflection
@@ -82,7 +79,6 @@ Autoloader: %{php_home}/%{ns_project}/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
%build
@@ -105,17 +101,18 @@ cp -pr lib %{buildroot}%{php_home}/%{ns_project}
%check
-%if %{with_tests}
+%if %{with tests}
mkdir vendor
-cat << 'EOF' | tee tests/bootstrap.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require '%{buildroot}%{php_home}/%{ns_project}/autoload.php';
EOF
ret=0
-for cmd in php php56 php70 php71 php72 php73 php74; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose || ret=1
+for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit9} $filter --verbose || ret=1
fi
done
exit $ret
@@ -134,6 +131,31 @@ exit $ret
%changelog
+* Thu Jun 30 2022 Remi Collet <remi@remirepo.net> - 1.0.6-1
+- update to 1.0.6 (unusable)
+- open https://github.com/khanamiryan/php-qrcode-detector-decoder/issues/124
+ Compatibility broken with PHP < 8.1
+
+* Tue Oct 5 2021 Remi Collet <remi@remirepo.net> - 1.0.5.2-1
+- update to 1.0.5.2
+
+* Wed Apr 21 2021 Remi Collet <remi@remirepo.net> - 1.0.5.1-1
+- update to 1.0.5.1
+- drop license patch merged upstream
+
+* Wed Apr 21 2021 Remi Collet <remi@remirepo.net> - 1.0.5-1
+- update to 1.0.5
+- drop PHP 8 patch merged upstream
+
+* Mon Nov 30 2020 Remi Collet <remi@remirepo.net> - 1.0.4-1
+- update to 1.0.4
+- add patch for PHP 8 from
+ https://github.com/khanamiryan/php-qrcode-detector-decoder/pull/103
+- switch to phpunit9
+
+* Mon Apr 20 2020 Remi Collet <remi@remirepo.net> - 1.0.3-1
+- update to 1.0.3
+
* Tue Sep 10 2019 Remi Collet <remi@remirepo.net> - 1.0.2-3
- add LICENSE files
- fix package summary and description