summaryrefslogtreecommitdiffstats
path: root/php-JsonSchema.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-JsonSchema.spec')
-rw-r--r--php-JsonSchema.spec14
1 files changed, 10 insertions, 4 deletions
diff --git a/php-JsonSchema.spec b/php-JsonSchema.spec
index 5f09374..d252e27 100644
--- a/php-JsonSchema.spec
+++ b/php-JsonSchema.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-JsonSchema
#
-# Copyright (c) 2012-2018 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2012-2021 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -33,10 +33,9 @@
Name: php-%{lib_name}
Version: %{github_version}
-Release: 10%{?dist}
+Release: 16%{?dist}
Summary: PHP implementation of JSON schema
-Group: Development/Libraries
License: BSD
URL: https://github.com/%{github_owner}/%{github_name}
# Use a git snapshot as upstream remove tests from distribution
@@ -46,6 +45,9 @@ Source2: %{name}-makesrc.sh
# https://github.com/justinrainbow/json-schema/pull/292
Patch0: %{name}-pr292.patch
+# Minimal patch for PHP 8
+Patch1: %{name}-php8.patch
+
BuildArch: noarch
%if %{with_tests}
@@ -100,6 +102,7 @@ See http://json-schema.org for more details.
%prep
%setup -qn %{github_name}-%{github_commit}
%patch0 -p1
+%patch1 -p1
: Create autoloader
cat <<'AUTOLOAD' | tee src/%{lib_name}/autoload.php
@@ -139,7 +142,7 @@ require '%{buildroot}%{phpdir}/%{lib_name}/autoload.php';
EOF
ret=0
-for cmd in php php70 php71 php72 php73; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
$cmd %{_bindir}/phpunit --verbose || ret=1
fi
@@ -161,6 +164,9 @@ exit $ret
%changelog
+* Wed Mar 31 2021 Remi Collet <remi@remirepo.net> - 1.6.1-16
+- add minimal patch for PHP 8
+
* Sun Dec 9 2018 Remi Collet <remi@remirepo.net> - 1.6.1-10
- cleanup for EL-8