summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-12-17 10:56:40 +0100
committerRemi Collet <fedora@famillecollet.com>2012-12-17 10:56:40 +0100
commite3d432c949cf80d2e08aa138f45c7755e5d5e944 (patch)
tree8c9df518c047c3d7a17f0fed1a638284dd0e7fdc /Makefile
parentebe248a4e1b5e8d4c2ec8dc2283df184a7c68a92 (diff)
php-JsonSchema: backport
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed