summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xmakesrc.sh1
-rw-r--r--php-jeremeamia-superclosure-autoload.php1
-rw-r--r--php-jeremeamia-superclosure.spec23
3 files changed, 19 insertions, 6 deletions
diff --git a/makesrc.sh b/makesrc.sh
index 24fbf81..e9a1ec5 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -16,6 +16,7 @@ git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
echo "Getting commit..."
pushd $PROJECT-$COMMIT
git checkout $COMMIT
+cp composer.json ../composer-$VERSION.json
popd
echo "Archiving..."
diff --git a/php-jeremeamia-superclosure-autoload.php b/php-jeremeamia-superclosure-autoload.php
index 059faf9..2ccdb0a 100644
--- a/php-jeremeamia-superclosure-autoload.php
+++ b/php-jeremeamia-superclosure-autoload.php
@@ -16,3 +16,4 @@ $fedoraClassLoader->addPrefix('SuperClosure\\', dirname(__DIR__));
// Dependencies
require_once $vendorDir . '/PhpParser/autoload.php';
+require_once $vendorDir . '/Symfony/Polyfill/autoload.php';
diff --git a/php-jeremeamia-superclosure.spec b/php-jeremeamia-superclosure.spec
index 9fb8d2b..a6a1a4f 100644
--- a/php-jeremeamia-superclosure.spec
+++ b/php-jeremeamia-superclosure.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
# Github
-%global gh_commit b712f39c671e5ead60c7ebfe662545456aade833
+%global gh_commit 29a88be2a4846d27c1613aed0c9071dfad7b5938
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner jeremeamia
%global gh_project super_closure
@@ -18,7 +18,7 @@
%global namespace SuperClosure
Name: php-%{pk_vendor}-%{pk_name}
-Version: 2.1.0
+Version: 2.2.0
Release: 1%{?dist}
Summary: Serialize Closure objects, including their context and binding
@@ -35,20 +35,23 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php(language) >= 5.4
BuildRequires: php-composer(nikic/php-parser) >= 1.4
+BuildRequires: php-composer(symfony/polyfill-php56) >= 1.0
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "~4.0",
-# "codeclimate/php-test-reporter": "~0.1.2"
+# "phpunit/phpunit": "^4.0|^5.0",
BuildRequires: php-composer(phpunit/phpunit) >= 4.0
# Autoloader
BuildRequires: php-composer(symfony/class-loader)
# From composer.json, "require": {
# "php": ">=5.4",
-# "nikic/php-parser": "~1.2"
+# "nikic/php-parser": "^1.2|^2.0",
+# "symfony/polyfill-php56": "^1.0"
# php-parser 1.4 for autoloader
Requires: php(language) >= 5.4
Requires: php-composer(nikic/php-parser) >= 1.4
-Requires: php-composer(nikic/php-parser) < 2
+Requires: php-composer(nikic/php-parser) < 3
+Requires: php-composer(symfony/polyfill-php56) >= 1.0
+Requires: php-composer(symfony/polyfill-php56) < 2
# From phpcompatifo report for 2.1.0
Requires: php-hash
Requires: php-reflection
@@ -95,6 +98,9 @@ EOF
%{_bindir}/phpunit -v
+if which php70; then
+ php70 %{_bindir}/phpunit -v
+fi
%clean
rm -rf %{buildroot}
@@ -109,5 +115,10 @@ rm -rf %{buildroot}
%changelog
+* Sun Dec 6 2015 Remi Collet <remi@fedoraproject.org> - 2.2.0-1
+- update to 2.2.0
+- run test suite with both php 5 and 7 when available
+- add dependency on symfony/polyfill-php56
+
* Tue Sep 1 2015 Remi Collet <remi@fedoraproject.org> - 2.1.0-1
- initial package \ No newline at end of file