summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-jeremeamia-superclosure-autoload.php6
-rw-r--r--php-jeremeamia-superclosure.spec7
2 files changed, 10 insertions, 3 deletions
diff --git a/php-jeremeamia-superclosure-autoload.php b/php-jeremeamia-superclosure-autoload.php
index 2ccdb0a..13f5b27 100644
--- a/php-jeremeamia-superclosure-autoload.php
+++ b/php-jeremeamia-superclosure-autoload.php
@@ -15,5 +15,9 @@ if (!isset($fedoraClassLoader) || !($fedoraClassLoader instanceof \Symfony\Compo
$fedoraClassLoader->addPrefix('SuperClosure\\', dirname(__DIR__));
// Dependencies
-require_once $vendorDir . '/PhpParser/autoload.php';
+if (file_exists($vendorDir . '/PhpParser2/autoload.php')) {
+ require_once $vendorDir . '/PhpParser2/autoload.php';
+} else {
+ require_once $vendorDir . '/PhpParser/autoload.php';
+}
require_once $vendorDir . '/Symfony/Polyfill/autoload.php';
diff --git a/php-jeremeamia-superclosure.spec b/php-jeremeamia-superclosure.spec
index 5cc2a48..fdf96b1 100644
--- a/php-jeremeamia-superclosure.spec
+++ b/php-jeremeamia-superclosure.spec
@@ -19,7 +19,7 @@
Name: php-%{pk_vendor}-%{pk_name}
Version: 2.2.0
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Serialize Closure objects, including their context and binding
Group: Development/Libraries
@@ -115,10 +115,13 @@ rm -rf %{buildroot}
%changelog
+* Sat May 21 2016 Remi Collet <remi@fedoraproject.org> - 2.2.0-2
+- use nikic/php-parser v2 when available
+
* Sun Dec 6 2015 Remi Collet <remi@fedoraproject.org> - 2.2.0-1
- update to 2.2.0
- run test suite with both php 5 and 7 when available
- add dependency on symfony/polyfill-php56
* Tue Sep 1 2015 Remi Collet <remi@fedoraproject.org> - 2.1.0-1
-- initial package \ No newline at end of file
+- initial package