summaryrefslogtreecommitdiffstats
path: root/php-horde-wicked.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-21 15:13:47 +0200
committerRemi Collet <remi@remirepo.net>2017-09-21 15:13:47 +0200
commit2a2848b9d43df4b93d009cd2cc92649c8f2a76f3 (patch)
tree4a96737515cd40d49073023de8c85bb7c42b4379 /php-horde-wicked.spec
parent2d963584cfb54ef5a503a0d739ecf4d6eda51866 (diff)
v2.0.8
Diffstat (limited to 'php-horde-wicked.spec')
-rw-r--r--php-horde-wicked.spec67
1 files changed, 39 insertions, 28 deletions
diff --git a/php-horde-wicked.spec b/php-horde-wicked.spec
index 1ae6847..588201f 100644
--- a/php-horde-wicked.spec
+++ b/php-horde-wicked.spec
@@ -6,16 +6,14 @@
#
# Please, preserve the changelog entries
#
-%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %global __pear %{_bindir}/pear}
%global pear_name wicked
%global pear_channel pear.horde.org
-# all tests are ignored
-%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+%global with_tests 0%{!?_without_tests:1}
Name: php-horde-wicked
-Version: 2.0.7
-Release: 2%{?dist}
+Version: 2.0.8
+Release: 1%{?dist}
Summary: Wiki application
Group: Development/Libraries
@@ -23,7 +21,6 @@ License: GPLv2
URL: http://www.horde.org/apps/wicked
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: gettext
BuildRequires: php(language) >= 5.3.0
@@ -31,6 +28,26 @@ BuildRequires: php-pear(PEAR) >= 1.7.0
BuildRequires: php-channel(%{pear_channel})
BuildRequires: php-pear(%{pear_channel}/Horde_Role) >= 1.0.0
%if %{with_tests}
+BuildRequires: php-pear(%{pear_channel}/horde) >= 5.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Auth) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Autoloader) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Core) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Db) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Form) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Http) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Lock) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Mail) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Mime) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Mime_Viewer) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Notification) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Perms) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Prefs) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Rpc) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Text_Diff) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Url) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Vfs) >= 2.0.0
BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
%endif
@@ -85,7 +102,6 @@ Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Util) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Vfs) >= 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Vfs) < 3.0.0
-Requires: php-pear(Text_Wiki) >= 1.2.0
# From package.xml, optional
Requires: php-pear(Text_Figlet)
# Optional and not yet available:
@@ -95,6 +111,9 @@ Requires: php-date
Requires: php-pcre
Requires: php-spl
+# Dead project, so bundled and maintained by Horde
+Provides: bundled(php-pear-Text-Wiki)
+
Provides: php-pear(%{pear_channel}/wicked) = %{version}
Provides: php-compposer(horde/wicked) = %{version}
Obsoletes: wicked < 2
@@ -146,7 +165,6 @@ done
%install
cd %{pear_name}-%{version}
-rm -rf %{buildroot}
%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
@@ -182,29 +200,18 @@ sed -e 's:#!/usr/bin/env php:#!%{_bindir}/php:' \
%if %{with_tests}
cd %{pear_name}-%{version}/test/Wicked
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit . || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit . || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose .
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose . || ret=1
+ fi
+done
exit $ret
+%else
+: Test disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%post
%{__pear} install --nodeps --soft --force --register-only \
%{pear_xmldir}/%{name}.xml >/dev/null || :
@@ -217,14 +224,13 @@ fi
%files -f %{pear_name}.lang
-%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
%config(noreplace) %{_sysconfdir}/httpd/conf.d/%{name}.conf
%attr(0770,apache,apache) %dir %{_sysconfdir}/horde/%{pear_name}
%attr(0640,apache,apache) %config %{_sysconfdir}/horde/%{pear_name}/*.dist
%attr(0660,apache,apache) %config %{_sysconfdir}/horde/%{pear_name}/*.xml
%{pear_xmldir}/%{name}.xml
-%{pear_testdir}/wicked
+%doc %{pear_testdir}/wicked
%{_bindir}/wicked
%{_bindir}/wicked-convert-to-utf8
%{_bindir}/wicked-mail-filter
@@ -241,6 +247,11 @@ fi
%changelog
+* Thu Sep 21 2017 Remi Collet <remi@remirepo.net> - 2.0.8-1
+- Update to 2.0.8
+- drop dependency on Text_Wiki
+- enable test suite
+
* Tue Dec 20 2016 Remi Collet <remi@fedoraproject.org> - 2.0.7-2
- Update to 2.0.7
- use upstream locale files