summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--kronolith-php72.patch12
-rw-r--r--php-horde-kronolith.spec13
2 files changed, 24 insertions, 1 deletions
diff --git a/kronolith-php72.patch b/kronolith-php72.patch
new file mode 100644
index 0000000..fd51596
--- /dev/null
+++ b/kronolith-php72.patch
@@ -0,0 +1,12 @@
+diff -up ./lib/Event.php.fix ./lib/Event.php
+--- ./lib/Event.php.fix 2017-10-13 14:30:50.754164418 +0200
++++ ./lib/Event.php 2017-10-13 14:31:04.412234396 +0200
+@@ -795,7 +795,7 @@ abstract class Kronolith_Event
+
+ // Tags
+ if ($this->tags) {
+- if (count($this->tags == 1)) {
++ if (count($this->tags) == 1) {
+ $vEvent->setAttribute('CATEGORIES', $this->tags[0]);
+ } else {
+ $vEvent->setAttribute('CATEGORIES', '', array(), true, $this->tags);
diff --git a/php-horde-kronolith.spec b/php-horde-kronolith.spec
index 0172819..c7dffe7 100644
--- a/php-horde-kronolith.spec
+++ b/php-horde-kronolith.spec
@@ -12,7 +12,7 @@
Name: php-horde-kronolith
Version: 4.2.23
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: A web based calendar
Group: Development/Libraries
@@ -20,6 +20,11 @@ License: GPLv2
URL: http://www.horde.org/apps/kronolith
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+# See comments on:
+# https://github.com/horde/kronolith/commit/9bfed34dc259824ddf1c3cd52fb6442f7f29d42b
+# https://github.com/horde/kronolith/commit/d996704daca092d92144f10d9f3d12e04f2b9dcb
+Patch0: %{pear_name}-php72.patch
+
BuildArch: noarch
BuildRequires: gettext
BuildRequires: php(language) >= 5.3.0
@@ -157,10 +162,13 @@ cat <<EOF | tee httpd.conf
EOF
cd %{pear_name}-%{version}
+%patch0 -p1 -b .php72
+
# Don't install .po and .pot files
# Remove checksum for .mo, as we regenerate them
sed -e '/%{pear_name}.po/d' \
-e '/htaccess/d' \
+ -e '/Event.php/s/md5sum=.*name=/name=/' \
-e '/%{pear_name}.mo/s/md5sum=.*name=/name=/' \
../package.xml >%{name}.xml
touch -r ../package.xml %{name}.xml
@@ -258,6 +266,9 @@ fi
%changelog
+* Fri Oct 13 2017 Remi Collet <remi@remirepo.net> - 4.2.23-2
+- add temporary patch for PHP 7.2, FTBFS from Koschei
+
* Tue Sep 19 2017 Remi Collet <remi@remirepo.net> - 4.2.23-1
- Update to 4.2.23