From 68e48f1e71096d14ffae9f2dc97fa9c8b51d476f Mon Sep 17 00:00:00 2001
From: Remi Collet <remi@remirepo.net>
Date: Mon, 18 Nov 2019 11:55:36 +0100
Subject: - update to 2.0.4 - drop patch merged upstream

---
 Horde_Xml_Wbxml-php74.patch    | 44 ------------------------------------------
 php-horde-Horde-Xml-Wbxml.spec | 18 ++++++++---------
 2 files changed, 8 insertions(+), 54 deletions(-)
 delete mode 100644 Horde_Xml_Wbxml-php74.patch

diff --git a/Horde_Xml_Wbxml-php74.patch b/Horde_Xml_Wbxml-php74.patch
deleted file mode 100644
index be35987..0000000
--- a/Horde_Xml_Wbxml-php74.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff --git a/lib/Horde/Xml/Wbxml/Decoder.php b/lib/Horde/Xml/Wbxml/Decoder.php
-index 2750a34..e1f71fe 100644
---- a/lib/Horde/Xml/Wbxml/Decoder.php
-+++ b/lib/Horde/Xml/Wbxml/Decoder.php
-@@ -89,7 +89,7 @@ class Horde_Xml_Wbxml_Decoder extends Horde_Xml_Wbxml_ContentHandler
-      */
-     public function getByte($input)
-     {
--        return ord($input{$this->_strpos++});
-+        return ord($input[$this->_strpos++]);
-     }
- 
-     /**
-diff --git a/lib/Horde/Xml/Wbxml/Encoder.php b/lib/Horde/Xml/Wbxml/Encoder.php
-index 69b14cb..dbacb86 100644
---- a/lib/Horde/Xml/Wbxml/Encoder.php
-+++ b/lib/Horde/Xml/Wbxml/Encoder.php
-@@ -49,7 +49,7 @@ class Horde_Xml_Wbxml_Encoder extends Horde_Xml_Wbxml_ContentHandler
-     /**
-      * Constructor.
-      */
--    public function Horde_Xml_Wbxml_Encoder()
-+    public function __construct()
-     {
-         $this->_dtdManager = new Horde_Xml_Wbxml_DtdManager();
-         $this->_stringTable = new Horde_Xml_Wbxml_HashTable();
-@@ -213,7 +213,7 @@ class Horde_Xml_Wbxml_Encoder extends Horde_Xml_Wbxml_ContentHandler
- 
-         $bytes = array();
-         for ($i = 0; $i < $nbytes; $i++) {
--            $bytes[] = $string{$i};
-+            $bytes[] = $string[$i];
-         }
- 
-         return $bytes;
-@@ -422,7 +422,7 @@ class Horde_Xml_Wbxml_Encoder extends Horde_Xml_Wbxml_ContentHandler
-             $this->_output .= chr(Horde_Xml_Wbxml::GLOBAL_TOKEN_SWITCH_PAGE);
-             $this->_output .= chr($cp);
-         } else {
--            $this->_subParser = new Horde_Xml_Wbxml_Encoder(true);
-+            $this->_subParser = new Horde_Xml_Wbxml_Encoder();
-             $this->_subParserStack = 1;
-         }
-     }
diff --git a/php-horde-Horde-Xml-Wbxml.spec b/php-horde-Horde-Xml-Wbxml.spec
index 7052fff..7766f71 100644
--- a/php-horde-Horde-Xml-Wbxml.spec
+++ b/php-horde-Horde-Xml-Wbxml.spec
@@ -12,16 +12,14 @@
 %global pear_channel pear.horde.org
 
 Name:           php-horde-Horde-Xml-Wbxml
-Version:        2.0.3
-Release:        8%{?dist}
+Version:        2.0.4
+Release:        1%{?dist}
 Summary:        Provides an API for encoding and decoding WBXML documents
 
 License:        LGPLv2
 URL:            http://%{pear_channel}
 Source0:        http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
 
-Patch0:         %{pear_name}-php74.patch
-
 BuildArch:      noarch
 BuildRequires:  php-common >= 5.3.0
 BuildRequires:  php-pear(PEAR) >= 1.7.0
@@ -66,11 +64,7 @@ with wireless devices.
 %setup -q -c
 
 cd %{pear_name}-%{version}
-%patch0 -p1
-
-sed -e '/.php/s/md5sum=.*name=/name=/' \
-    ../package.xml >%{name}.xml
-touch -r ../package.xml %{name}.xml
+mv ../package.xml %{name}.xml
 
 
 %build
@@ -101,7 +95,7 @@ sed -e '/assertEquals/s/^/if ($xml_ref) /' \
 ret=0
 for cmd in php php71 php72 php73 php74; do
   if which $cmd; then
-    $cmd %{_bindir}/phpunit --verbose . || ret=1
+    $cmd %{_bindir}/phpunit --bootstrap=bootstrap.php --verbose . || ret=1
   fi
 done
 exit $ret
@@ -128,6 +122,10 @@ fi
 
 
 %changelog
+* Mon Nov 18 2019 Remi Collet <remi@remirepo.net> - 2.0.4-1
+- update to 2.0.4
+- drop patch merged upstream
+
 * Fri Nov 15 2019 Remi Collet <remi@fedoraproject.org> - 2.0.3-8
 - add patch for PHP 7.4
   from https://github.com/horde/Xml_Wbxml/pull/1
-- 
cgit