summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-Vfs.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-03-04 08:35:14 +0100
committerRemi Collet <fedora@famillecollet.com>2014-03-04 08:35:14 +0100
commit278307979620ea2e6e8270d7a51d0aab15c700a6 (patch)
tree8fa6e4877a7449de860f80f77c603ebc1d04fa8f /php-horde-Horde-Vfs.spec
parent12cbeefc4c699ba84c36667eead628d54a60111f (diff)
php-horde-Horde-Vfs: 2.2.0
Diffstat (limited to 'php-horde-Horde-Vfs.spec')
-rw-r--r--php-horde-Horde-Vfs.spec26
1 files changed, 20 insertions, 6 deletions
diff --git a/php-horde-Horde-Vfs.spec b/php-horde-Horde-Vfs.spec
index ac83172..24ddd10 100644
--- a/php-horde-Horde-Vfs.spec
+++ b/php-horde-Horde-Vfs.spec
@@ -1,11 +1,20 @@
-%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+# spec file for php-horde-Horde-Vfs
+#
+# Copyright (c) 2012-2014 Nick Bebout, Remi Collet
+#
+# License: MIT
+# https://fedoraproject.org/wiki/Licensing:MIT#Modern_Style_with_sublicense
+#
+# Please, preserve the changelog entries
+#
+%{!?__pear: %global __pear %{_bindir}/pear}
%global pear_name Horde_Vfs
%global pear_channel pear.horde.org
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: php-horde-Horde-Vfs
-Version: 2.1.2
+Version: 2.2.0
Release: 1%{?dist}
Summary: Virtual File System API
@@ -23,7 +32,7 @@ BuildRequires: gettext
%if %{with_tests}
# To run unit tests
BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
-BuildRequires: php-pear(%{pear_channel}/Horde_Db) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Db) >= 2.1.0
%endif
Requires(post): %{__pear}
@@ -116,15 +125,16 @@ done | tee ../%{pear_name}.lang
%check
%if %{with_tests}
+src=$(pwd)/%{pear_name}-%{version}
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
# Failed asserting that file "/tmp/vfsfiletest/.horde/foo/高&执&行&力&的&打&造.txt" exists.
sed -e 's/testDeleteUnusalFileNames/SKIP_testDeleteUnusalFileNames/' \
-i FileTest.php
phpunit \
- -d date.timezone=UTC \
- -d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
- .
+ -d include_path=$src/lib:.:%{pear_phpdir} \
+ -d date.timezone=UTC \
+ .
%else
: Test disabled
%endif
@@ -155,6 +165,10 @@ fi
%changelog
+* Tue Mar 04 2014 Remi Collet <remi@fedoraproject.org> - 2.2.0-1
+- Update to 2.2.0
+- raise dependency on Horde_Db >= 2.1.0
+
* Mon Oct 28 2013 Remi Collet <remi@fedoraproject.org> - 2.1.2-1
- Update to 2.1.2
- skip 1 failed test instead of ignoring test result