summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-Thrift.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-horde-Horde-Thrift.spec')
-rw-r--r--php-horde-Horde-Thrift.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/php-horde-Horde-Thrift.spec b/php-horde-Horde-Thrift.spec
new file mode 100644
index 0000000..197e964
--- /dev/null
+++ b/php-horde-Horde-Thrift.spec
@@ -0,0 +1,84 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Horde_Thrift
+%global pear_channel pear.horde.org
+
+Name: php-horde-Horde-Thrift
+Version: 2.0.0
+Release: 1%{?dist}
+Summary: Thrift
+
+Group: Development/Libraries
+License: ASL 2.0
+URL: http://pear.horde.org
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-channel(%{pear_channel})
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php(language) >= 5.3.0
+Requires: php-date
+Requires: php-spl
+Requires: php-pear(PEAR) >= 1.7.0
+Requires: php-channel(%{pear_channel})
+# Optionnal: APC
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+%description
+Packaged version of the PHP Thrift client
+
+Optional extension : php-pecl-apc
+
+
+%prep
+%setup -q -c -T
+tar xif %{SOURCE0}
+
+cd %{pear_name}-%{version}
+mv ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/Thrift
+%{pear_phpdir}/Horde/Thrift.php
+
+
+%changelog
+* Mon Nov 5 2012 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
+- Initial package