summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-horde-Horde-Support-uuid.patch26
-rw-r--r--php-horde-Horde-Support.spec20
2 files changed, 8 insertions, 38 deletions
diff --git a/php-horde-Horde-Support-uuid.patch b/php-horde-Horde-Support-uuid.patch
deleted file mode 100644
index 09974d7..0000000
--- a/php-horde-Horde-Support-uuid.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff -up Horde_Support-2.0.0/lib/Horde/Support/Uuid.php.old Horde_Support-2.0.0/lib/Horde/Support/Uuid.php
---- Horde_Support-2.0.0/lib/Horde/Support/Uuid.php.old 2012-11-06 17:23:48.000000000 +0100
-+++ Horde_Support-2.0.0/lib/Horde/Support/Uuid.php 2012-11-06 17:36:23.000000000 +0100
-@@ -36,9 +36,20 @@ class Horde_Support_Uuid
- */
- public function generate()
- {
-+ $this->_uuid = NULL;
- if (extension_loaded('uuid')) {
-- $this->_uuid = uuid_create();
-- } else {
-+ if (function_exists("uuid_export")) {
-+ // UUID extension from http://www.ossp.org/pkg/lib/uuid/
-+ if (uuid_create($ctx)==UUID_RC_OK && uuid_make($ctx, UUID_MAKE_V4)==UUID_RC_OK && uuid_export($ctx, UUID_FMT_STR, $str)==UUID_RC_OK) {
-+ $this->_uuid = $str;
-+ uuid_destroy($ctx);
-+ }
-+ } else {
-+ // UUID extension from http://pecl.php.net/package/uuid
-+ $this->_uuid = uuid_create();
-+ }
-+ }
-+ if (!$this->_uuid) {
- list($time_mid, $time_low) = explode(' ', microtime());
- $time_low = (int)$time_low;
- $time_mid = (int)substr($time_mid, 2) & 0xffff;
diff --git a/php-horde-Horde-Support.spec b/php-horde-Horde-Support.spec
index 747d28d..05060fa 100644
--- a/php-horde-Horde-Support.spec
+++ b/php-horde-Horde-Support.spec
@@ -7,8 +7,8 @@
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
Name: php-horde-Horde-Support
-Version: 2.0.0
-Release: 3%{?dist}
+Version: 2.0.1
+Release: 1%{?dist}
Summary: Horde support package
Group: Development/Libraries
@@ -16,10 +16,6 @@ License: BSD
URL: http://pear.horde.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-# http://bugs.horde.org/ticket/11653
-# Make compatible with both existing UUID extensions
-Patch0: %{name}-uuid.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
BuildRequires: php-pear(PEAR) >= 1.7.0
@@ -52,14 +48,10 @@ Optional dependencies:
%prep
-%setup -q -c -T
-tar xif %{SOURCE0}
+%setup -q -c
cd %{pear_name}-%{version}
-%patch0 -p1 -b .uuid
-
-sed -e '/Uuid.php/s/md5sum=.*name/name/' \
- ../package.xml >%{name}.xml
+cp ../package.xml %{name}.xml
%build
@@ -108,6 +100,10 @@ fi
%changelog
+* Wed Nov 7 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.1-3
+- Update to 2.0.1 for remi repo
+- drop our patch, merged upstream
+
* Tue Nov 6 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.0-3
- add patch to allow uuid-php or php-pecl-uuid