summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-11-09 15:18:44 +0100
committerRemi Collet <fedora@famillecollet.com>2014-11-09 15:18:44 +0100
commit8f3f6433b6ce05a38822cc60e6d635d951d324ec (patch)
treee5e6bc0219abb63d619eff2e5e39da541770393e
php-horde-Horde-Stringprep: 1.0.0 - new package
-rw-r--r--Horde_Stringprep-syslib.patch16
-rw-r--r--Makefile4
-rw-r--r--php-horde-Horde-Stringprep.spec103
3 files changed, 123 insertions, 0 deletions
diff --git a/Horde_Stringprep-syslib.patch b/Horde_Stringprep-syslib.patch
new file mode 100644
index 0000000..bda50a5
--- /dev/null
+++ b/Horde_Stringprep-syslib.patch
@@ -0,0 +1,16 @@
+diff -up Horde_Stringprep-1.0.0/lib/Horde/Stringprep.php.old Horde_Stringprep-1.0.0/lib/Horde/Stringprep.php
+--- Horde_Stringprep-1.0.0/lib/Horde/Stringprep.php.old 2014-11-09 14:58:55.000000000 +0100
++++ Horde_Stringprep-1.0.0/lib/Horde/Stringprep.php 2014-11-09 14:59:50.000000000 +0100
+@@ -34,11 +34,7 @@ class Horde_Stringprep
+ */
+ public static function autoload()
+ {
+- if (file_exists(__DIR__ . '/vendor/autoload.php')) {
+- require_once __DIR__ . '/vendor/autoload.php';
+- } else {
+- require_once __DIR__ . '/../../../bundle/vendor/autoload.php';
+- }
++ require_once('/usr/share/php/Znerol/Component/Stringprep/autoload.php');
+ }
+
+ }
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-Horde-Stringprep.spec b/php-horde-Horde-Stringprep.spec
new file mode 100644
index 0000000..e58852b
--- /dev/null
+++ b/php-horde-Horde-Stringprep.spec
@@ -0,0 +1,103 @@
+# spec file for php-horde-Horde-Stringprep
+#
+# Copyright (c) 2014 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %global __pear %{_bindir}/pear}
+%global pear_name Horde_Stringprep
+%global pear_channel pear.horde.org
+
+Name: php-horde-Horde-Stringprep
+Version: 1.0.0
+Release: 1%{?dist}
+Summary: Preparation of Internationalized Strings ("stringprep")
+
+Group: Development/Libraries
+License: LGPLv3
+URL: http://www.horde.org/
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+# use system library instead of bundled copy
+Patch0: %{pear_name}-syslib.patch
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php(language) >= 5.3.0
+BuildRequires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-channel(%{pear_channel})
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php(language) >= 5.3.0
+Requires: php-pear(PEAR) >= 1.7.0
+Requires: php-channel(%{pear_channel})
+# Unbundled library
+Requires: php-composer(znerol/php-stringprep)
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+
+%description
+Horde wrapper around the znerol/php-stringprep package.
+
+
+%prep
+%setup -q -c
+cd %{pear_name}-%{version}
+
+%patch0 -p1 -b .syslib
+
+sed -e '/bundle/d' \
+ -e '/Stringprep.php/s/md5sum=.*name=/name=/' \
+ ../package.xml >%{name}.xml
+touch -r ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+rm -rf %{buildroot}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%dir %{pear_phpdir}/Horde
+%{pear_phpdir}/Horde/Stringprep.php
+
+
+%changelog
+* Sun Nov 9 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- Initial package, version 1.0.0 \ No newline at end of file