summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-06-08 09:49:19 +0200
committerRemi Collet <fedora@famillecollet.com>2014-06-08 09:49:19 +0200
commitdf113be1814ba70df62ba44df0a32a87ef9d861a (patch)
tree270430d02268833ca281e6f3a33fcb9191dac9b1
parent85225ee778cb4a69dbb409e9a71e184dfed47bff (diff)
horde: fix FTBFS (include path) + cleanups
-rw-r--r--php-horde-Horde-Stream-Filter.spec17
1 files changed, 13 insertions, 4 deletions
diff --git a/php-horde-Horde-Stream-Filter.spec b/php-horde-Horde-Stream-Filter.spec
index 112f625..4cfdac3 100644
--- a/php-horde-Horde-Stream-Filter.spec
+++ b/php-horde-Horde-Stream-Filter.spec
@@ -1,5 +1,13 @@
-%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
-%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+# spec file for php-horde-Horde-Stream-Filter
+#
+# Copyright (c) 2012-2014 Nick Bebout, Remi Collet
+#
+# License: MIT
+# https://fedoraproject.org/wiki/Licensing:MIT#Modern_Style_with_sublicense
+#
+# Please, preserve the changelog entries
+#
+%{!?__pear: %global __pear %{_bindir}/pear}
%global pear_name Horde_Stream_Filter
%global pear_channel pear.horde.org
@@ -59,9 +67,10 @@ install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
+src=$(pwd)/%{pear_name}-%{version}
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-phpunit\
- -d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
+phpunit \
+ --include-path=$src/lib \
-d date.timezone=UTC \
.