summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-Share.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-horde-Horde-Share.spec')
-rw-r--r--php-horde-Horde-Share.spec43
1 files changed, 29 insertions, 14 deletions
diff --git a/php-horde-Horde-Share.spec b/php-horde-Horde-Share.spec
index 25b45a5..de7e08f 100644
--- a/php-horde-Horde-Share.spec
+++ b/php-horde-Horde-Share.spec
@@ -3,8 +3,12 @@
%global pear_name Horde_Share
%global pear_channel pear.horde.org
+# not ready
+# Fatal error: Cannot make static method PHPUnit_Framework_Assert::callback() non static in class Horde_Share_Test_Base
+%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+
Name: php-horde-Horde-Share
-Version: 2.0.1
+Version: 2.0.2
Release: 1%{?dist}
Summary: Horde Shared Permissions System
@@ -12,16 +16,16 @@ Group: Development/Libraries
License: LGPLv2
URL: http://pear.horde.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-# /usr/lib/rpm/find-lang.sh from fedora 16
-Source1: find-lang.sh
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-pear(PEAR) >= 1.7.0
BuildRequires: php-channel(%{pear_channel})
BuildRequires: gettext
+%if %{with_tests}
# To run unit tests
-BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
+%endif
Requires(post): %{__pear}
Requires(postun): %{__pear}
@@ -87,16 +91,25 @@ rm -rf %{buildroot}%{pear_metadir}/.??*
mkdir -p %{buildroot}%{pear_xmldir}
install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
-%if 0%{?fedora} > 13
-%find_lang %{pear_name}
-%else
-sh %{SOURCE1} %{buildroot} %{pear_name}
-%endif
+# Locales
+for loc in locale/{??,??_??}
+do
+ lang=$(basename $loc)
+ test -d %{buildroot}%{pear_datadir}/%{pear_name}/$loc \
+ && echo "%%lang(${lang%_*}) %{pear_datadir}/%{pear_name}/$loc"
+done | tee ../%{pear_name}.lang
%check
+%if %{with_tests}
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-# not ready: phpunit -d date.timezone=UTC AllTests.php
+phpunit \
+ -d date.timezone=UTC \
+ -d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
+ .
+%else
+: Test disabled, missing '--with tests' option.
+%endif
%post
@@ -110,20 +123,22 @@ if [ $1 -eq 0 ] ; then
fi
-%files -f %{pear_name}-%{version}/%{pear_name}.lang
+%files -f %{pear_name}.lang
%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Horde/Share
%{pear_testdir}/%{pear_name}
-# own locales (non standard) directories, .mo own by find_lang
%dir %{pear_datadir}/%{pear_name}
%dir %{pear_datadir}/%{pear_name}/locale
-%dir %{pear_datadir}/%{pear_name}/locale/*
-%dir %{pear_datadir}/%{pear_name}/locale/*/LC_MESSAGES
%changelog
+* Thu Jan 10 2013 Remi Collet <RPMS@FamilleCollet.com> - 2.0.2-1
+- Update to 2.0.2 for remi repo
+- use local script instead of find_lang
+- add option for test (need investigation)
+
* Wed Nov 7 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.1-1
- Update to 2.0.1 for remi repo