summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-Perms.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-horde-Horde-Perms.spec')
-rw-r--r--php-horde-Horde-Perms.spec32
1 files changed, 18 insertions, 14 deletions
diff --git a/php-horde-Horde-Perms.spec b/php-horde-Horde-Perms.spec
index c459dfd..69bfa31 100644
--- a/php-horde-Horde-Perms.spec
+++ b/php-horde-Horde-Perms.spec
@@ -4,7 +4,7 @@
%global pear_channel pear.horde.org
Name: php-horde-Horde-Perms
-Version: 2.0.1
+Version: 2.0.2
Release: 1%{?dist}
Summary: Horde Permissions System
@@ -12,8 +12,6 @@ Group: Development/Libraries
License: LGPLv2+
URL: http://pear.horde.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-# /usr/lib/rpm/find-lang.sh from fedora 16
-Source1: find-lang.sh
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
@@ -21,7 +19,7 @@ BuildRequires: php-pear(PEAR) >= 1.7.0
BuildRequires: php-channel(%{pear_channel})
BuildRequires: gettext
# To run unit tests
-BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
BuildRequires: php-pear(%{pear_channel}/Horde_Group) >= 2.0.0
Requires(post): %{__pear}
@@ -84,16 +82,20 @@ rm -rf %{buildroot}%{pear_metadir}/.??*
mkdir -p %{buildroot}%{pear_xmldir}
install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
-%if 0%{?fedora} > 13
-%find_lang %{pear_name}
-%else
-sh %{SOURCE1} %{buildroot} %{pear_name}
-%endif
+for loc in locale/{??,??_??}
+do
+ lang=$(basename $loc)
+ test -d %{buildroot}%{pear_datadir}/%{pear_name}/$loc \
+ && echo "%%lang(${lang%_*}) %{pear_datadir}/%{pear_name}/$loc"
+done | tee ../%{pear_name}.lang
%check
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-phpunit -d date.timezone=UTC AllTests.php
+phpunit \
+ -d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
+ -d date.timezone=UTC \
+ .
%post
@@ -107,22 +109,24 @@ if [ $1 -eq 0 ] ; then
fi
-%files -f %{pear_name}-%{version}/%{pear_name}.lang
+%files -f %{pear_name}.lang
%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Horde/Perms
%{pear_phpdir}/Horde/Perms.php
%{pear_testdir}/%{pear_name}
-# own locales (non standard) directories, .mo own by find_lang
%dir %{pear_datadir}/%{pear_name}
%dir %{pear_datadir}/%{pear_name}/locale
-%dir %{pear_datadir}/%{pear_name}/locale/*
-%dir %{pear_datadir}/%{pear_name}/locale/*/LC_MESSAGES
%{pear_datadir}/%{pear_name}/migration
%changelog
+* Wed Jan 9 2013 Remi Collet <RPMS@FamilleCollet.com> - 2.0.2-1
+- Update to 2.0.2 for remi repo
+- use local script instead of find_lang
+- new test layout (requires Horde_Test 2.1.0)
+
* Wed Nov 7 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.1-1
- Update to 2.0.1 for remi repo