summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-Pdf.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-horde-Horde-Pdf.spec')
-rw-r--r--php-horde-Horde-Pdf.spec115
1 files changed, 115 insertions, 0 deletions
diff --git a/php-horde-Horde-Pdf.spec b/php-horde-Horde-Pdf.spec
new file mode 100644
index 0000000..ab104a0
--- /dev/null
+++ b/php-horde-Horde-Pdf.spec
@@ -0,0 +1,115 @@
+# spec file for php-horde-Horde-Pdf
+#
+# Copyright (c) 2014 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{!?__pear: %global __pear %{_bindir}/pear}
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%global pear_name Horde_Pdf
+%global pear_channel pear.horde.org
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+
+Name: php-horde-Horde-Pdf
+Version: 2.0.3
+Release: 1%{?dist}
+Summary: Horde PDF library
+
+Group: Development/Libraries
+License: LGPLv2
+URL: http://%{pear_channel}
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php(language) >= 5.3.0
+BuildRequires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-channel(%{pear_channel})
+%if %{with_tests}
+# To run unit tests
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
+%endif
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+# From package.xml, required
+Requires: php(language) >= 5.3.0
+Requires: php-pear(PEAR) >= 1.7.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) < 3.0.0
+Requires: php-channel(%{pear_channel})
+# From phpcompatinfo report for version 2.0.3
+Requires: php-date
+Requires: php-zlib
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+
+%description
+PDF generation using only PHP, without requiring any external libraries.
+
+
+%prep
+%setup -q -c
+
+cd %{pear_name}-%{version}
+mv ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+rm -rf %{buildroot}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%check
+%if %{with_tests}
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+phpunit \
+ -d date.timezone=UTC \
+ .
+%else
+: Test disabled, missing '--with tests' option.
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/Pdf
+%{pear_testdir}/%{pear_name}
+
+
+%changelog
+* Sun Sep 14 2014 Remi Collet <remi@fedoraproject.org> - 2.0.3-1
+- initial package \ No newline at end of file