summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-Pdf.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-10-17 15:59:04 +0200
committerRemi Collet <remi@remirepo.net>2019-10-17 15:59:04 +0200
commitc002cdfa2010ab32753bc5691f4afd6992b15055 (patch)
treeda56bf85afcf575421b38eac0c565373738a009c /php-horde-Horde-Pdf.spec
parenta372f0b9787570b4c9a34270be0923c5037f4c86 (diff)
- add patch for PHP 7.4 from
https://github.com/horde/Pdf/pull/1 use range dependencies
Diffstat (limited to 'php-horde-Horde-Pdf.spec')
-rw-r--r--php-horde-Horde-Pdf.spec49
1 files changed, 33 insertions, 16 deletions
diff --git a/php-horde-Horde-Pdf.spec b/php-horde-Horde-Pdf.spec
index a43bf33..f4d297a 100644
--- a/php-horde-Horde-Pdf.spec
+++ b/php-horde-Horde-Pdf.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-horde-Horde-Pdf
#
-# Copyright (c) 2014-2017 Remi Collet
+# Copyright (c) 2014-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -13,33 +13,44 @@
Name: php-horde-Horde-Pdf
Version: 2.0.7
-Release: 1%{?dist}
+Release: 8%{?dist}
Summary: Horde PDF library
-Group: Development/Libraries
License: LGPLv2
URL: http://%{pear_channel}
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+Patch0: https://patch-diff.githubusercontent.com/raw/horde/Pdf/pull/1.patch
+
BuildArch: noarch
BuildRequires: php(language) >= 5.3.0
BuildRequires: php-pear(PEAR) >= 1.7.0
BuildRequires: php-channel(%{pear_channel})
%if %{with_tests}
# To run unit tests
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-pear(%{pear_channel}/Horde_Test) >= 2.1.0 with php-pear(%{pear_channel}/Horde_Test) < 3)
+BuildRequires: (php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Exception) < 3)
+BuildRequires: (php-pear(%{pear_channel}/Horde_Util) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Util) < 3)
+%else
BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
%endif
+%endif
Requires(post): %{__pear}
Requires(postun): %{__pear}
# From package.xml, required
Requires: php(language) >= 5.3.0
Requires: php-pear(PEAR) >= 1.7.0
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Exception) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Util) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Util) < 3)
+%else
Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Exception) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Util) < 3.0.0
+%endif
Requires: php-channel(%{pear_channel})
# From phpcompatinfo report for version 2.0.3
Requires: php-date
@@ -55,9 +66,11 @@ PDF generation using only PHP, without requiring any external libraries.
%prep
%setup -q -c
-
cd %{pear_name}-%{version}
-mv ../package.xml %{name}.xml
+%patch0 -p1 -b .pr1
+
+sed -e '/Writer.php/s/md5sum=.*name=/name=/' \
+ ../package.xml >%{name}.xml
%build
@@ -67,7 +80,6 @@ cd %{pear_name}-%{version}
%install
cd %{pear_name}-%{version}
-rm -rf %{buildroot}
%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
@@ -81,18 +93,19 @@ install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
%if %{with_tests}
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-%{_bindir}/phpunit .
-if which php70; then
- php70 %{_bindir}/phpunit .
-fi
+ret=0
+for cmd in php php71 php72 php73 php74; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose . || ret=1
+ fi
+done
+exit $ret
%else
: Test disabled, missing '--with tests' option.
%endif
-%clean
-rm -rf %{buildroot}
%post
@@ -107,14 +120,18 @@ fi
%files
-%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Horde/Pdf
-%{pear_testdir}/%{pear_name}
+%doc %{pear_testdir}/%{pear_name}
%changelog
+* Thu Oct 17 2019 Remi Collet <remi@remirepo.net> - 2.0.7-8
+- add patch for PHP 7.4 from
+ https://github.com/horde/Pdf/pull/1
+- use range dependencies
+
* Tue Feb 02 2016 Remi Collet <remi@fedoraproject.org> - 2.0.7-1
- Update to 2.0.7
- PHP 7 compatible version
@@ -132,4 +149,4 @@ fi
- add provides php-composer(horde/horde-pdf)
* Sun Sep 14 2014 Remi Collet <remi@fedoraproject.org> - 2.0.3-1
-- initial package \ No newline at end of file
+- initial package