summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-Kolab-Format.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-03-28 18:25:43 +0100
committerRemi Collet <fedora@famillecollet.com>2013-03-28 18:25:43 +0100
commit32be26e821e568f8614b9817866cab54d3e13efe (patch)
treeb39329c506023bd34a7a533bbfda2878702ef8be /php-horde-Horde-Kolab-Format.spec
php-horde-Horde-Kolab-Format: new package
Diffstat (limited to 'php-horde-Horde-Kolab-Format.spec')
-rw-r--r--php-horde-Horde-Kolab-Format.spec113
1 files changed, 113 insertions, 0 deletions
diff --git a/php-horde-Horde-Kolab-Format.spec b/php-horde-Horde-Kolab-Format.spec
new file mode 100644
index 0000000..7e1b847
--- /dev/null
+++ b/php-horde-Horde-Kolab-Format.spec
@@ -0,0 +1,113 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Horde_Kolab_Format
+%global pear_channel pear.horde.org
+
+Name: php-horde-Horde-Kolab-Format
+Version: 2.0.3
+Release: 1%{?dist}
+Summary: A package for reading/writing Kolab data formats
+
+Group: Development/Libraries
+License: LGPLv2
+URL: http://%{pear_channel}/
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php(language) >= 5.3.0
+BuildRequires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-channel(%{pear_channel})
+# To run unit tests
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php(language) >= 5.3.0
+Requires: php-date
+Requires: php-dom
+Requires: php-ereg
+Requires: php-mbstring
+Requires: php-pcre
+Requires: php-spl
+Requires: php-pear(PEAR) >= 1.7.0
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+# Optional
+Requires: php-pear(%{pear_channel}/Horde_Support) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Support) >= 3.0.0
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+%description
+This package allows to convert Kolab data objects from XML to data arrays.
+
+
+%prep
+%setup -q -c
+cd %{pear_name}-%{version}
+mv ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%check
+src=$(pwd)/%{pear_name}-%{version}
+
+# fix for unit consistency in sources tree
+# waiting for upstream explanation on this issue
+sed -e '/VERSION =/s/%{version}/@version@/' \
+ -i $src/lib/Horde/Kolab/Format.php
+
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+phpunit \
+ -d include_path=$src/lib:.:%{pear_phpdir} \
+ -d date.timezone=UTC \
+ .
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%dir %{pear_phpdir}/Horde/Kolab
+%{pear_phpdir}/Horde/Kolab/Format
+%{pear_phpdir}/Horde/Kolab/Format.php
+%{pear_testdir}/%{pear_name}
+
+
+%changelog
+* Thu Mar 28 2013 Remi Collet <RPMS@FamilleCollet.com> - 2.0.3-1
+- initial package