summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-07-08 19:30:55 +0200
committerRemi Collet <fedora@famillecollet.com>2014-07-08 19:30:55 +0200
commit0817c551e84bf1dc3a38b01e3fa2101aa0feaabe (patch)
tree5e2fdbbf0d9543336efe38ddec56d2662f192468
php-horde-Horde-JavascriptMinify: 1.0.0 - new package
-rw-r--r--Makefile4
-rw-r--r--php-horde-Horde-JavascriptMinify.spec102
2 files changed, 106 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-Horde-JavascriptMinify.spec b/php-horde-Horde-JavascriptMinify.spec
new file mode 100644
index 0000000..1c32edd
--- /dev/null
+++ b/php-horde-Horde-JavascriptMinify.spec
@@ -0,0 +1,102 @@
+# spec file for php-horde-Horde-JavascriptMinify
+#
+# Copyright (c) 2014 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %global __pear %{_bindir}/pear}
+%global pear_name Horde_JavascriptMinify
+%global pear_channel pear.horde.org
+
+Name: php-horde-Horde-JavascriptMinify
+Version: 1.1.0
+Release: 1%{?dist}
+Summary: Javascript Minification
+
+Group: Development/Libraries
+License: LGPLv2
+URL: http://pear.horde.org/
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php(language) >= 5.3.0
+BuildRequires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-channel(%{pear_channel})
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+# From package.xml
+Requires: php(language) >= 5.3.0
+Requires: php-pear(PEAR) >= 1.7.0
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) < 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Log) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Log) < 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) < 3.0.0
+# From phpcompatinfo report for version 1.0.0
+Requires: php-json
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+
+%description
+Abstracted interface to various javascript minification backends.
+
+
+%prep
+%setup -q -c
+
+cd %{pear_name}-%{version}
+mv ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+rm -rf %{buildroot}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ pear.horde.org/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/JavascriptMinify/
+%{pear_phpdir}/Horde/JavascriptMinify.php
+
+
+%changelog
+* Tue Jul 8 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- Initial package, verison 1.0.0 \ No newline at end of file