summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--9.patch22
-rw-r--r--php-horde-Horde-Imap-Client.spec12
2 files changed, 6 insertions, 28 deletions
diff --git a/9.patch b/9.patch
deleted file mode 100644
index 4ecf872..0000000
--- a/9.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From fac0813d75d9ab552985667eb4ed74f188679e65 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Tue, 1 Oct 2019 13:38:23 +0200
-Subject: [PATCH] Trying to access array offset on value of type null (7.4)
-
----
- lib/Horde/Imap/Client/Socket/ClientSort.php | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/lib/Horde/Imap/Client/Socket/ClientSort.php b/lib/Horde/Imap/Client/Socket/ClientSort.php
-index 4030492a..a93853ab 100644
---- a/lib/Horde/Imap/Client/Socket/ClientSort.php
-+++ b/lib/Horde/Imap/Client/Socket/ClientSort.php
-@@ -110,7 +110,7 @@ public function clientSort($res, $opts)
- }
-
- $mbox = $this->_socket->currentMailbox();
-- $fetch_res = $this->_socket->fetch($mbox['mailbox'], $query, array(
-+ $fetch_res = $this->_socket->fetch(isset($mbox['mailbox']) ? $mbox['mailbox'] : null, $query, array(
- 'ids' => $res
- ));
-
diff --git a/php-horde-Horde-Imap-Client.spec b/php-horde-Horde-Imap-Client.spec
index ed26051..b6576ec 100644
--- a/php-horde-Horde-Imap-Client.spec
+++ b/php-horde-Horde-Imap-Client.spec
@@ -12,16 +12,14 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-horde-Horde-Imap-Client
-Version: 2.30.0
-Release: 2%{?dist}
+Version: 2.30.1
+Release: 1%{?dist}
Summary: Horde IMAP abstraction interface
License: LGPLv2
URL: http://pear.horde.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-Patch0: https://patch-diff.githubusercontent.com/raw/horde/Imap_Client/pull/9.patch
-
BuildArch: noarch
BuildRequires: php(language) >= 5.3.0
BuildRequires: php-pear(PEAR) >= 1.7.0
@@ -124,13 +122,11 @@ drivers.
%prep
%setup -q -c
cd %{pear_name}-%{version}
-%patch0 -p1
# Don't install .po and .pot files
# Remove checksum for .mo, as we regenerate them
sed -e '/%{pear_name}\.po/d' \
-e '/%{pear_name}\.mo/s/md5sum=.*name=/name=/' \
- -e '/ClientSort.php/s/md5sum=.*name=/name=/' \
../package.xml >%{name}.xml
touch -r ../package.xml %{name}.xml
@@ -209,6 +205,10 @@ fi
%changelog
+* Mon Nov 4 2019 Remi Collet <remi@remirepo.net> - 2.30.1-1
+- update to 2.30.1
+- drop patch merged upstream
+
* Tue Oct 1 2019 Remi Collet <remi@remirepo.net> - 2.30.0-2
- add patch for PHP 7.4 from
https://github.com/horde/Imap_Client/pull/9