summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-horde-Horde-Exception.spec34
1 files changed, 24 insertions, 10 deletions
diff --git a/php-horde-Horde-Exception.spec b/php-horde-Horde-Exception.spec
index e67def6..4b68128 100644
--- a/php-horde-Horde-Exception.spec
+++ b/php-horde-Horde-Exception.spec
@@ -1,12 +1,24 @@
-%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+# spec file for php-horde-Horde-Exception
+#
+# Copyright (c) 2012-2015 Nick Bebout, Remi Collet
+#
+# License: MIT
+# https://fedoraproject.org/wiki/Licensing:MIT#Modern_Style_with_sublicense
+#
+# Please, preserve the changelog entries
+#
+%{!?__pear: %global __pear %{_bindir}/pear}
+%global bootstrap 0
%global pear_name Horde_Exception
%global pear_channel pear.horde.org
-
-# Can run test because of circular dependency with Horde_Test
+%if %{bootstrap}
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+%else
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+%endif
Name: php-horde-Horde-Exception
-Version: 2.0.4
+Version: 2.0.5
Release: 1%{?dist}
Summary: Horde Exception Handler
@@ -32,10 +44,11 @@ Requires: php(language) >= 5.3.0
Requires: php-spl
Requires: php-pear(PEAR) >= 1.7.0
Requires: php-channel(%{pear_channel})
-Requires: php-pear(%{pear_channel}/Horde_Translation) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Translation) >= 2.2.0
Requires: php-pear(%{pear_channel}/Horde_Translation) < 3.0.0
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+Provides: php-composer(horde/horde-exception) = %{version}
%description
@@ -87,12 +100,8 @@ done | tee ../%{pear_name}.lang
%check
%if %{with_tests}
-src=$(pwd)/%{pear_name}-%{version}
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-phpunit \
- -d include_path=$src/lib:.:%{pear_phpdir} \
- -d date.timezone=UTC \
- .
+phpunit .
%else
: Test disabled, missing '--with tests' option.
%endif
@@ -121,6 +130,11 @@ fi
%changelog
+* Thu Jan 08 2015 Remi Collet <remi@fedoraproject.org> - 2.0.5-1
+- Update to 2.0.5
+- add provides php-composer(horde/horde-exception)
+- raise dependency on Horde_Translation 2.2.0
+
* Tue Aug 27 2013 Remi Collet <remi@fedoraproject.org> - 2.0.4-1
- Update to 2.0.4