summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-Editor.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-horde-Horde-Editor.spec')
-rw-r--r--php-horde-Horde-Editor.spec9
1 files changed, 9 insertions, 0 deletions
diff --git a/php-horde-Horde-Editor.spec b/php-horde-Horde-Editor.spec
index d5e8b78..848f7d3 100644
--- a/php-horde-Horde-Editor.spec
+++ b/php-horde-Horde-Editor.spec
@@ -86,6 +86,15 @@ ln -s %{_datadir}/ckeditor %{buildroot}%{pear_hordedir}/js/ckeditor
rm -rf %{buildroot}
+%pre
+# directory replace by a link
+lib=%{pear_hordedir}/js/ckeditor
+if [ -d $lib -a ! -L $lib ]
+then
+ rm -rf $lib
+fi
+
+
%post
%{__pear} install --nodeps --soft --force --register-only \
%{pear_xmldir}/%{name}.xml >/dev/null || :