summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-Date-Parser.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-horde-Horde-Date-Parser.spec')
-rw-r--r--php-horde-Horde-Date-Parser.spec17
1 files changed, 13 insertions, 4 deletions
diff --git a/php-horde-Horde-Date-Parser.spec b/php-horde-Horde-Date-Parser.spec
index 5fa6e1a..59a1a47 100644
--- a/php-horde-Horde-Date-Parser.spec
+++ b/php-horde-Horde-Date-Parser.spec
@@ -1,4 +1,12 @@
-%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+# spec file for php-horde-Horde-Kolab-Format
+#
+# Copyright (c) 2013-2014 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{!?__pear: %global __pear %{_bindir}/pear}
%global pear_name Horde_Date_Parser
%global pear_channel pear.horde.org
@@ -29,9 +37,9 @@ Requires: php-pcre
Requires: php-spl
Requires: php-pear(PEAR) >= 1.7.0
Requires: php-pear(%{pear_channel}/Horde_Date) >= 2.0.0
-Conflicts: php-pear(%{pear_channel}/Horde_Date) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Date) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Support) >= 2.0.0
-Conflicts: php-pear(%{pear_channel}/Horde_Support) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Support) < 3.0.0
Requires: php-channel(%{pear_channel})
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
@@ -67,9 +75,10 @@ install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
+src=$(pwd)/%{pear_name}-%{version}
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
phpunit\
- -d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
+ --include-path=$src/lib \
-d date.timezone=UTC \
.