summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--0002-drop-ereg-dep-for-php-7-in-Date_Parser.patch58
-rw-r--r--php-horde-Horde-Date-Parser.spec13
2 files changed, 5 insertions, 66 deletions
diff --git a/0002-drop-ereg-dep-for-php-7-in-Date_Parser.patch b/0002-drop-ereg-dep-for-php-7-in-Date_Parser.patch
deleted file mode 100644
index 75c3672..0000000
--- a/0002-drop-ereg-dep-for-php-7-in-Date_Parser.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From d197a50a3b6d8a74a9f690d75ef595d4b5b6fa27 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Mon, 27 Jun 2016 07:28:40 +0200
-Subject: [PATCH 2/2] drop ereg dep for php 7 in Date_Parser
-
----
- .../lib/Horde/Date/Parser/Locale/Pt.php | 28 +++++++++++-----------
- 1 file changed, 14 insertions(+), 14 deletions(-)
-
-diff --git a/framework/Date_Parser/lib/Horde/Date/Parser/Locale/Pt.php b/framework/Date_Parser/lib/Horde/Date/Parser/Locale/Pt.php
-index 53ab624..77bf7eb 100644
---- a/framework/Date_Parser/lib/Horde/Date/Parser/Locale/Pt.php
-+++ b/framework/Date_Parser/lib/Horde/Date/Parser/Locale/Pt.php
-@@ -130,14 +130,14 @@ class Horde_Date_Parser_Locale_Pt extends Horde_Date_Parser_Locale_Base
- public function normalize_special_characters( $str )
- {
- # Quotes cleanup
-- $str = ereg_replace( chr(ord("`")), "'", $str ); # `
-- $str = ereg_replace( chr(ord("´")), "'", $str ); # ´
-- $str = ereg_replace( chr(ord("„")), ",", $str ); # „
-- $str = ereg_replace( chr(ord("`")), "'", $str ); # `
-- $str = ereg_replace( chr(ord("´")), "'", $str ); # ´
-- $str = ereg_replace( chr(ord("“")), "\"", $str ); # “
-- $str = ereg_replace( chr(ord("”")), "\"", $str ); # ”
-- $str = ereg_replace( chr(ord("´")), "'", $str ); # ´
-+ $str = str_replace( chr(ord("`")), "'", $str ); # `
-+ $str = str_replace( chr(ord("´")), "'", $str ); # ´
-+ $str = str_replace( chr(ord("„")), ",", $str ); # „
-+ $str = str_replace( chr(ord("`")), "'", $str ); # `
-+ $str = str_replace( chr(ord("´")), "'", $str ); # ´
-+ $str = str_replace( chr(ord("“")), "\"", $str ); # “
-+ $str = str_replace( chr(ord("”")), "\"", $str ); # ”
-+ $str = str_replace( chr(ord("´")), "'", $str ); # ´
-
- $unwanted_array = array('Š'=>'S', 'š'=>'s', 'Ž'=>'Z', 'ž'=>'z', 'À'=>'A', 'Á'=>'A', 'Â'=>'A', 'Ã'=>'A', 'Ä'=>'A', 'Å'=>'A', 'Æ'=>'A', 'Ç'=>'C', 'È'=>'E', 'É'=>'E',
- 'Ê'=>'E', 'Ë'=>'E', 'Ì'=>'I', 'Í'=>'I', 'Î'=>'I', 'Ï'=>'I', 'Ñ'=>'N', 'Ò'=>'O', 'Ó'=>'O', 'Ô'=>'O', 'Õ'=>'O', 'Ö'=>'O', 'Ø'=>'O', 'Ù'=>'U',
-@@ -147,12 +147,12 @@ class Horde_Date_Parser_Locale_Pt extends Horde_Date_Parser_Locale_Base
- $str = strtr( $str, $unwanted_array );
-
- # Bullets, dashes, and trademarks
-- $str = ereg_replace( chr(149), "&#8226;", $str ); # bullet •
-- $str = ereg_replace( chr(150), "&ndash;", $str ); # en dash
-- $str = ereg_replace( chr(151), "&mdash;", $str ); # em dash
-- $str = ereg_replace( chr(153), "&#8482;", $str ); # trademark
-- $str = ereg_replace( chr(169), "&copy;", $str ); # copyright mark
-- $str = ereg_replace( chr(174), "&reg;", $str ); # registration mark
-+ $str = str_replace( chr(149), "&#8226;", $str ); # bullet •
-+ $str = str_replace( chr(150), "&ndash;", $str ); # en dash
-+ $str = str_replace( chr(151), "&mdash;", $str ); # em dash
-+ $str = str_replace( chr(153), "&#8482;", $str ); # trademark
-+ $str = str_replace( chr(169), "&copy;", $str ); # copyright mark
-+ $str = str_replace( chr(174), "&reg;", $str ); # registration mark
-
- return $str;
- }
---
-2.5.5
-
diff --git a/php-horde-Horde-Date-Parser.spec b/php-horde-Horde-Date-Parser.spec
index 119a937..24e7e02 100644
--- a/php-horde-Horde-Date-Parser.spec
+++ b/php-horde-Horde-Date-Parser.spec
@@ -11,8 +11,8 @@
%global pear_channel pear.horde.org
Name: php-horde-Horde-Date-Parser
-Version: 2.0.5
-Release: 2%{?dist}
+Version: 2.0.6
+Release: 1%{?dist}
Summary: Horde Date Parser
Group: Development/Libraries
@@ -20,9 +20,6 @@ License: LGPLv2
URL: http://pear.horde.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-# https://github.com/horde/horde/pull/195
-Patch0: 0002-drop-ereg-dep-for-php-7-in-Date_Parser.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php(language) >= 5.3.0
@@ -60,9 +57,6 @@ languages and locales
cd %{pear_name}-%{version}
mv ../package.xml %{name}.xml
-%patch0 -p3 -b .ereg
-sed -e '/Pt.php/s/md5sum="[^"]*"//' \
- -i %{name}.xml
%build
@@ -112,6 +106,9 @@ fi
%changelog
+* Wed Jul 13 2016 Remi Collet <remi@fedoraproject.org> - 2.0.6-1
+- Update to 2.0.6
+
* Mon Jun 27 2016 Remi Collet <remi@fedoraproject.org> - 2.0.5-2
- add patch to drop dependency on ereg