summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-Data.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-04 11:14:52 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-04 11:14:52 +0100
commit85a3f5c2057d900be3ed318415abfa8a8e6c47e0 (patch)
tree593bf6be76106eb91722e2fc8e910c8359540e95 /php-horde-Horde-Data.spec
parent2601a6d25dcb684e13d4c0db7fdeaaa7e47f9807 (diff)
php-horde-Horde-Data: 2.0.0
Diffstat (limited to 'php-horde-Horde-Data.spec')
-rw-r--r--php-horde-Horde-Data.spec89
1 files changed, 57 insertions, 32 deletions
diff --git a/php-horde-Horde-Data.spec b/php-horde-Horde-Data.spec
index 9ae6cf8..facb49b 100644
--- a/php-horde-Horde-Data.spec
+++ b/php-horde-Horde-Data.spec
@@ -1,35 +1,45 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
-%global pear_name Horde_Data
+%global pear_name Horde_Data
+%global pear_channel pear.horde.org
Name: php-horde-Horde-Data
-Version: 1.0.7
-Release: 2%{?dist}
+Version: 2.0.0
+Release: 1%{?dist}
Summary: Horde Data API
Group: Development/Libraries
License: LGPLv2+
URL: http://pear.horde.org
-Source0: http://pear.horde.org/get/%{pear_name}-%{version}.tgz
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+# /usr/lib/rpm/find-lang.sh from fedora 16
+Source1: find-lang.sh
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-pear(PEAR) >= 1.7.0
-BuildRequires: php-channel(pear.horde.org)
+BuildRequires: php-channel(%{pear_channel})
BuildRequires: gettext
+BuildRequires: gettext
+# To run unit tests
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.0.0
Requires(post): %{__pear}
Requires(postun): %{__pear}
-Requires: php-pear(pear.horde.org/Horde_Browser) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Exception) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Icalendar) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Mime) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Translation) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Util) < 2.0.0
-Requires: php-pear(PEAR) >= 1.7.0
-Requires: php-channel(pear.horde.org)
-Requires: php-date php-pcre
-Requires: php-common >= 5.2.0
-
-Provides: php-pear(pear.horde.org/%{pear_name}) = %{version}
+Requires: php(language) >= 5.3.0
+Requires: php-date
+Requires: php-pcre
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Browser) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Icalendar) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Mail) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Mime) < 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Translation) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
%description
A data import and export API, with backends for:
@@ -41,11 +51,8 @@ A data import and export API, with backends for:
* vTodo
%prep
-%setup -q -c
-
-# Create a "localized" php.ini to avoid build warning
-cp /etc/php.ini .
-echo "date.timezone=UTC" >>php.ini
+%setup -q -c -T
+tar xif %{SOURCE0}
cd %{pear_name}-%{version}
@@ -55,6 +62,7 @@ sed -e '/%{pear_name}.po/d' \
-e '/%{pear_name}.mo/s/md5sum=.*name=/name=/' \
../package.xml >%{name}.xml
+
%build
cd %{pear_name}-%{version}
@@ -64,17 +72,29 @@ do
msgfmt $po -o $(dirname $po)/$(basename $po .po).mo
done
+
%install
cd %{pear_name}-%{version}
-PHPRC=../php.ini %{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+%if 0%{?fedora} > 13
%find_lang %{pear_name}
+%else
+sh %{SOURCE1} %{buildroot} %{pear_name}
+%endif
+
+
+%check
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+phpunit -d date.timezone=UTC AllTests.php
+
%post
%{__pear} install --nodeps --soft --force --register-only \
@@ -83,22 +103,27 @@ install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
%postun
if [ $1 -eq 0 ] ; then
%{__pear} uninstall --nodeps --ignore-errors --register-only \
- pear.horde.org/%{pear_name} >/dev/null || :
+ %{pear_channel}/%{pear_name} >/dev/null || :
fi
+
%files -f %{pear_name}-%{version}/%{pear_name}.lang
%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Horde/Data
%{pear_phpdir}/Horde/Data.php
-%{pear_testdir}/Horde_Data
+%{pear_testdir}/%{pear_name}
# own locales (non standard) directories, .mo own by find_lang
-%dir %{pear_datadir}/Horde_Data
-%dir %{pear_datadir}/Horde_Data/locale
-%dir %{pear_datadir}/Horde_Data/locale/*
-%dir %{pear_datadir}/Horde_Data/locale/*/LC_MESSAGES
+%dir %{pear_datadir}/%{pear_name}
+%dir %{pear_datadir}/%{pear_name}/locale
+%dir %{pear_datadir}/%{pear_name}/locale/*
+%dir %{pear_datadir}/%{pear_name}/locale/*/LC_MESSAGES
+
%changelog
+* Sun Nov 4 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.0-1
+- Update to 2.0.0 for remi repo
+
* Mon Jun 25 2012 Nick Bebout <nb@fedoraproject.org> - 1.0.7-2
- Add requires for php-common