summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-CssMinify.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-07-08 19:10:05 +0200
committerRemi Collet <fedora@famillecollet.com>2014-07-08 19:10:05 +0200
commit1b2de86c9ab9a8bcbafb6ca8e1ebbc1585e13a53 (patch)
treea9c2fac6f8bb82dddd74a10dca326bc3f08f4123 /php-horde-Horde-CssMinify.spec
php-horde-Horde-CssMinify: 1.0.0 - New package
Diffstat (limited to 'php-horde-Horde-CssMinify.spec')
-rw-r--r--php-horde-Horde-CssMinify.spec101
1 files changed, 101 insertions, 0 deletions
diff --git a/php-horde-Horde-CssMinify.spec b/php-horde-Horde-CssMinify.spec
new file mode 100644
index 0000000..acbc080
--- /dev/null
+++ b/php-horde-Horde-CssMinify.spec
@@ -0,0 +1,101 @@
+# spec file for php-horde-Horde-CssMinify
+#
+# Copyright (c) 2014 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %global __pear %{_bindir}/pear}
+%global pear_name Horde_CssMinify
+%global pear_channel pear.horde.org
+
+Name: php-horde-Horde-CssMinify
+Version: 1.0.0
+Release: 1%{?dist}
+Summary: CSS Minification
+
+Group: Development/Libraries
+License: LGPLv2
+URL: http://pear.horde.org
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php(language) >= 5.3.0
+BuildRequires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-channel(%{pear_channel})
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php(language) >= 5.3.0
+Requires: php-pear(PEAR) >= 1.7.0
+Requires: php-pear(%{pear_channel}/Horde_Css_Parser) >= 1.0.0
+Requires: php-pear(%{pear_channel}/Horde_Css_Parser) < 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) < 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Log) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Log) < 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Url) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Url) < 3.0.0
+Requires: php-channel(%{pear_channel})
+
+Provides: php-pear(%{pear_channel}/Horde_CssMinify) = %{version}
+
+
+%description
+Abstracted interface to various CSS minification backends.
+
+
+%prep
+%setup -q -c
+
+cd %{pear_name}-%{version}
+mv ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+rm -rf %{buildroot}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ pear.horde.org/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/CssMinify.php
+%{pear_phpdir}/Horde/CssMinify/
+
+
+%changelog
+* Tue Jul 8 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- Initial package, verison 1.0.0 \ No newline at end of file