summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-horde-Horde-Controller.spec27
1 files changed, 18 insertions, 9 deletions
diff --git a/php-horde-Horde-Controller.spec b/php-horde-Horde-Controller.spec
index fa6cd16..fd4686b 100644
--- a/php-horde-Horde-Controller.spec
+++ b/php-horde-Horde-Controller.spec
@@ -1,5 +1,13 @@
-%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
-%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+# spec file for php-horde-Horde-Controller
+#
+# Copyright (c) 2012-2014 Nick Bebout, Remi Collet
+#
+# License: MIT
+# https://fedoraproject.org/wiki/Licensing:MIT#Modern_Style_with_sublicense
+#
+# Please, preserve the changelog entries
+#
+%{!?__pear: %global __pear %{_bindir}/pear}
%global pear_name Horde_Controller
%global pear_channel pear.horde.org
@@ -27,15 +35,15 @@ Requires: php-mbstring
Requires: php-zlib
Requires: php-channel(%{pear_channel})
Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
-Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Injector) >= 2.0.0
-Conflicts: php-pear(%{pear_channel}/Horde_Injector) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Injector) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Log) >= 2.0.0
-Conflicts: php-pear(%{pear_channel}/Horde_Log) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Log) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Support) >= 2.0.0
-Conflicts: php-pear(%{pear_channel}/Horde_Support) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Support) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
-Conflicts: php-pear(%{pear_channel}/Horde_Util) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) < 3.0.0
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
@@ -68,9 +76,10 @@ mkdir -p %{buildroot}%{pear_xmldir}
install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
+src=$(pwd)/%{pear_name}-%{version}
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-phpunit\
- -d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
+phpunit \
+ --include-path=$src/lib \
-d date.timezone=UTC \
.