summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-02 19:03:01 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-02 19:03:01 +0100
commit5e5da06f3b2fd903bd1d0fe0ab768753d71e7517 (patch)
treed865a6b339741f29efcd9c04aa0cdad85f2e8de0
parent1e40114f9afb7ae68971446db0c0be1d8d1d763f (diff)
php-horde-Horde-Controller: 2.0.0
-rw-r--r--Makefile4
-rw-r--r--php-horde-Horde-Controller.spec78
2 files changed, 52 insertions, 30 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-Horde-Controller.spec b/php-horde-Horde-Controller.spec
index 2323997..2002309 100644
--- a/php-horde-Horde-Controller.spec
+++ b/php-horde-Horde-Controller.spec
@@ -1,47 +1,54 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
-%global pear_name Horde_Controller
+%global pear_name Horde_Controller
+%global pear_channel pear.horde.org
Name: php-horde-Horde-Controller
-Version: 1.0.2
-Release: 2%{?dist}
+Version: 2.0.0
+Release: 1%{?dist}
Summary: Horde Controller libraries
Group: Development/Libraries
License: BSD
URL: http://pear.horde.org
-Source0: http://pear.horde.org/get/%{pear_name}-%{version}.tgz
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
BuildRequires: php-pear >= 1.7.0
-BuildRequires: php-channel(pear.horde.org)
+BuildRequires: php-channel(%{pear_channel})
+# To run unit tests
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.0.0
Requires(post): %{__pear}
Requires(postun): %{__pear}
-Requires: php-pear(pear.horde.org/Horde_Exception) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Injector) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Log) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Support) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Util) < 2.0.0
-Requires: php-pear(PEAR) >= 1.7.0
-Requires: php-channel(pear.horde.org)
-Requires: php-common >= 5.2.0
-Requires: php-mbstring php-zlib
-
-Provides: php-pear(pear.horde.org/%{pear_name}) = %{version}
+Requires: php(language) >= 5.3.0
+Requires: php-mbstring
+Requires: php-zlib
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Injector) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Injector) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Log) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Log) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Support) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Support) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Util) >= 3.0.0
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
%description
This package provides the controller part of an MVC system for Horde.
%prep
-%setup -q -c
-[ -f package2.xml ] || mv package.xml package2.xml
-mv package2.xml %{pear_name}-%{version}/%{name}.xml
-
-# Create a "localized" php.ini to avoid build warning
-cp /etc/php.ini .
-echo "date.timezone=UTC" >>php.ini
+%setup -q -c -T
+tar xif %{SOURCE0}
cd %{pear_name}-%{version}
+cp ../package.xml %{name}.xml
%build
@@ -51,14 +58,19 @@ cd %{pear_name}-%{version}
%install
cd %{pear_name}-%{version}
-PHPRC=../php.ini %{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+%check
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+phpunit AllTests.php
+
%post
%{__pear} install --nodeps --soft --force --register-only \
@@ -67,17 +79,23 @@ install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
%postun
if [ $1 -eq 0 ] ; then
%{__pear} uninstall --nodeps --ignore-errors --register-only \
- pear.horde.org/%{pear_name} >/dev/null || :
+ %{pear_channel}/%{pear_name} >/dev/null || :
fi
+
%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Horde/Controller
%{pear_phpdir}/Horde/Controller.php
-%{pear_testdir}/Horde_Controller
-%doc %{pear_docdir}/Horde_Controller/COPYING
+%{pear_testdir}/%{pear_name}
+
%changelog
+* Fri Nov 2 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.0-1
+- Update to 2.0.0 for remi repo
+
* Mon Jun 25 2012 Nick Bebout <nb@fedoraproject.org> - 1.0.2-2
- Fix requires