summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-Compress.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-03 08:25:37 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-03 08:25:37 +0100
commitfa0e7d2e230ffdfeba97a2f9208aa8947ffaf1de (patch)
tree02e4459a0b346e4ac878e75248bb87038fb2a6fd /php-horde-Horde-Compress.spec
parent70b382396acce01d70e6d1579f397253c3c7fb63 (diff)
php-horde-Horde-Compress: 2.0.0
Diffstat (limited to 'php-horde-Horde-Compress.spec')
-rw-r--r--php-horde-Horde-Compress.spec84
1 files changed, 55 insertions, 29 deletions
diff --git a/php-horde-Horde-Compress.spec b/php-horde-Horde-Compress.spec
index 02d0d6a..e6ee2a6 100644
--- a/php-horde-Horde-Compress.spec
+++ b/php-horde-Horde-Compress.spec
@@ -1,43 +1,52 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
-%global pear_name Horde_Compress
+%global pear_name Horde_Compress
+%global pear_channel pear.horde.org
Name: php-horde-Horde-Compress
-Version: 1.0.7
-Release: 2%{?dist}
+Version: 2.0.0
+Release: 1%{?dist}
Summary: Horde Compression API
Group: Development/Libraries
License: LGPLv2+
URL: http://pear.horde.org
-Source0: http://pear.horde.org/get/%{pear_name}-%{version}.tgz
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+# /usr/lib/rpm/find-lang.sh from fedora 16
+Source1: find-lang.sh
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
-BuildRequires: php-pear(PEAR) >= 1.7.0
-BuildRequires: php-channel(pear.horde.org)
+BuildRequires: php-pear
+BuildRequires: php-channel(%{pear_channel})
BuildRequires: gettext
+# To run unit tests
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Stream_Filter) >= 2.0.0
Requires(post): %{__pear}
Requires(postun): %{__pear}
-Requires: php-pear(pear.horde.org/Horde_Exception) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Translation) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Util) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Stream_Filter) < 2.0.0
-Requires: php-pear(PEAR) >= 1.7.0
-Requires: php-channel(pear.horde.org)
+Requires: php(language) >= 5.3.0
Requires: php-date php-pcre php-zlib
-Requires: php-common >= 5.2.0
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Translation) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Translation) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Util) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Stream_Filter) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Stream_Filter) >= 3.0.0
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
-Provides: php-pear(pear.horde.org/%{pear_name}) = %{version}
%description
An API for various compression techniques.
%prep
-%setup -q -c
-
-# Create a "localized" php.ini to avoid build warning
-cp /etc/php.ini .
-echo "date.timezone=UTC" >>php.ini
+%setup -q -c -T
+tar xif %{SOURCE0}
cd %{pear_name}-%{version}
@@ -47,6 +56,7 @@ sed -e '/%{pear_name}.po/d' \
-e '/%{pear_name}.mo/s/md5sum=.*name=/name=/' \
../package.xml >%{name}.xml
+
%build
cd %{pear_name}-%{version}
@@ -56,17 +66,29 @@ do
msgfmt $po -o $(dirname $po)/$(basename $po .po).mo
done
+
%install
cd %{pear_name}-%{version}
-PHPRC=../php.ini %{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+%if 0%{?fedora} > 13
%find_lang %{pear_name}
+%else
+sh %{SOURCE1} %{buildroot} %{pear_name}
+%endif
+
+
+%check
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+phpunit -d date.timezone=UTC AllTests.php
+
%post
%{__pear} install --nodeps --soft --force --register-only \
@@ -75,7 +97,7 @@ install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
%postun
if [ $1 -eq 0 ] ; then
%{__pear} uninstall --nodeps --ignore-errors --register-only \
- pear.horde.org/%{pear_name} >/dev/null || :
+ %{pear_channel}/%{pear_name} >/dev/null || :
fi
%files -f %{pear_name}-%{version}/%{pear_name}.lang
@@ -83,14 +105,18 @@ fi
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Horde/Compress
%{pear_phpdir}/Horde/Compress.php
-%{pear_testdir}/Horde_Compress
+%{pear_testdir}/%{pear_name}
# own locales (non standard) directories, .mo own by find_lang
-%dir %{pear_datadir}/Horde_Compress
-%dir %{pear_datadir}/Horde_Compress/locale
-%dir %{pear_datadir}/Horde_Compress/locale/*
-%dir %{pear_datadir}/Horde_Compress/locale/*/LC_MESSAGES
+%dir %{pear_datadir}/%{pear_name}
+%dir %{pear_datadir}/%{pear_name}/locale
+%dir %{pear_datadir}/%{pear_name}/locale/*
+%dir %{pear_datadir}/%{pear_name}/locale/*/LC_MESSAGES
+
%changelog
+* Sat Nov 3 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.0-1
+- Update to 2.0.0 for remi repo
+
* Mon Jun 25 2012 Nick Bebout <nb@fedoraproject.org> - 1.0.7-2
- Fix requires