summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-01 19:17:12 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-01 19:17:12 +0100
commit659f5c5755abe0d7b015ac182123a2dff39f74e8 (patch)
tree0d1d07ee5bcfacc17fd069be048d4dc8e907aa65
parentb7bc0accc4cb225b6c52a337f6d3ad00861c22d2 (diff)
php-horde-Horde-Cache: 2.0.0
-rw-r--r--Makefile4
-rw-r--r--php-horde-Horde-Cache.spec54
2 files changed, 38 insertions, 20 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-Horde-Cache.spec b/php-horde-Horde-Cache.spec
index bc2fb31..978b82c 100644
--- a/php-horde-Horde-Cache.spec
+++ b/php-horde-Horde-Cache.spec
@@ -1,26 +1,33 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
-%global pear_name Horde_Cache
+%global pear_name Horde_Cache
+%global pear_channel pear.horde.org
Name: php-horde-Horde-Cache
-Version: 1.0.5
+Version: 2.0.0
Release: 1%{?dist}
Summary: Horde Caching API
Group: Development/Libraries
License: LGPLv2+
URL: http://pear.horde.org
-Source0: http://pear.horde.org/get/%{pear_name}-%{version}.tgz
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
-BuildRequires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-pear
+BuildRequires: php-channel(%{pear_channel})
+
Requires(post): %{__pear}
Requires(postun): %{__pear}
-Requires: php-pear(pear.horde.org/Horde_Exception) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Util) <= 2.0.0
-Requires: php-pear(PEAR) >= 1.7.0
-Provides: php-pear(pear.horde.org/Horde_Cache) = %{version}
-BuildRequires: php-channel(pear.horde.org)
-Requires: php-channel(pear.horde.org)
+Requires: php(language) >= 5.3.0
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Util) >= 3.0.0
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
%description
This package provides a simple, functional caching API, with the option to
@@ -29,11 +36,11 @@ systems (APC, eAcclerator, XCache, or Zend Performance Suite's content
cache), memcached, or an SQL table.
%prep
-%setup -q -c
-[ -f package2.xml ] || mv package.xml package2.xml
-mv package2.xml %{pear_name}-%{version}/%{name}.xml
+%setup -q -c -T
+tar xif %{SOURCE0}
cd %{pear_name}-%{version}
+cp ../package.xml %{name}.xml
%build
@@ -43,14 +50,15 @@ cd %{pear_name}-%{version}
%install
cd %{pear_name}-%{version}
-%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
%post
%{__pear} install --nodeps --soft --force --register-only \
@@ -59,17 +67,23 @@ install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
%postun
if [ $1 -eq 0 ] ; then
%{__pear} uninstall --nodeps --ignore-errors --register-only \
- pear.horde.org/%{pear_name} >/dev/null || :
+ %{pear_channel}/%{pear_name} >/dev/null || :
fi
+
%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Horde/Cache
%{pear_phpdir}/Horde/Cache.php
-%{pear_datadir}/Horde_Cache
-%doc %{pear_docdir}/Horde_Cache/COPYING
+%{pear_datadir}/%{pear_name}
+
%changelog
+* Thu Nov 1 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.0-1
+- Update to 2.0.0 for remi repo
+
* Thu Jun 21 2012 Nick Bebout <nb@fedoraproject.org> - 1.0.5-1
- Upgrade to 1.0.5