summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-horde-Horde-Argv.spec15
1 files changed, 10 insertions, 5 deletions
diff --git a/php-horde-Horde-Argv.spec b/php-horde-Horde-Argv.spec
index f415c51..7b767f5 100644
--- a/php-horde-Horde-Argv.spec
+++ b/php-horde-Horde-Argv.spec
@@ -4,7 +4,7 @@
%global pear_channel pear.horde.org
Name: php-horde-Horde-Argv
-Version: 2.0.0
+Version: 2.0.1
Release: 1%{?dist}
Summary: Horde command-line argument parsing package
@@ -17,7 +17,7 @@ Source1: find-lang.sh
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
-BuildRequires: php-pear
+BuildRequires: php-pear(PEAR) >= 1.7.0
BuildRequires: php-channel(%{pear_channel})
BuildRequires: gettext
# To run unit tests
@@ -26,6 +26,9 @@ BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.0.0
Requires(post): %{__pear}
Requires(postun): %{__pear}
Requires: php(language) >= 5.3.0
+Requires: php-reflection
+Requires: php-spl
+Requires: php-pear(PEAR) >= 1.7.0
Requires: php-channel(%{pear_channel})
Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
@@ -41,9 +44,7 @@ help, grouping options, and more.
%prep
-%setup -q -c -T
-tar xif %{SOURCE0}
-
+%setup -q -c
cd %{pear_name}-%{version}
# Don't install .po and .pot files
@@ -95,6 +96,7 @@ if [ $1 -eq 0 ] ; then
%{pear_channel}/%{pear_name} >/dev/null || :
fi
+
%files -f %{pear_name}-%{version}/%{pear_name}.lang
%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
@@ -109,6 +111,9 @@ fi
%changelog
+* Wed Nov 7 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.1-1
+- Update to 2.0.1 for remi repo
+
* Thu Nov 1 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.0-1
- Update to 2.0.0 for remi repo
- run test during rpmbuild