summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-Alarm.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-02 11:33:12 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-02 11:33:12 +0100
commit26833d650317fe2fec39ee48c9468cea993828be (patch)
tree61ea72541a2fa4f1dcbb4f279cba4eaf68bf7d9c /php-horde-Horde-Alarm.spec
parent091db93cd1c64364aba60354d710369e98df6280 (diff)
php-horde-Horde-Alarm: 2.0.0
Diffstat (limited to 'php-horde-Horde-Alarm.spec')
-rw-r--r--php-horde-Horde-Alarm.spec80
1 files changed, 58 insertions, 22 deletions
diff --git a/php-horde-Horde-Alarm.spec b/php-horde-Horde-Alarm.spec
index 039be9b..ab149c8 100644
--- a/php-horde-Horde-Alarm.spec
+++ b/php-horde-Horde-Alarm.spec
@@ -1,44 +1,63 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
-%global pear_name Horde_Alarm
+%global pear_name Horde_Alarm
+%global pear_channel pear.horde.org
Name: php-horde-Horde-Alarm
-Version: 1.0.7
+Version: 2.0.0
Release: 1%{?dist}
Summary: Horde Alarm Libraries
Group: Development/Libraries
License: LGPLv2+
URL: http://pear.horde.org
-Source0: http://pear.horde.org/get/%{pear_name}-%{version}.tgz
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+# /usr/lib/rpm/find-lang.sh from fedora 16
+Source1: find-lang.sh
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
BuildRequires: php-pear(PEAR) >= 1.7.0
BuildRequires: gettext
+BuildRequires: php-channel(%{pear_channel})
+# To run unit tests
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Date) >= 2.0.0
+
Requires(post): %{__pear}
Requires(postun): %{__pear}
-Requires: php-pear(pear.horde.org/Horde_Date) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Exception) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Translation) < 2.0.0
-Requires: php-pear(PEAR) >= 1.7.0
-Provides: php-pear(pear.horde.org/Horde_Alarm) = %{version}
-BuildRequires: php-channel(pear.horde.org)
-Requires: php-channel(pear.horde.org)
+Requires: php(language) >= 5.3.0
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Date) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Date) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Translation) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Translation) >= 3.0.0
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
%description
An interface to deal with reminders, alarms and notifications through a
standardized API. The following notification methods are currently
available: standard Horde notifications, pop-ups, emails.
+
%prep
-%setup -q -c
+%setup -q -c -T
+tar xif %{SOURCE0}
+
cd %{pear_name}-%{version}
# Don't install .po and .pot files
# Remove checksum for .mo, as we regenerate them
sed -e '/%{pear_name}.po/d' \
+ -e '/Horde_Other.po/d' \
-e '/%{pear_name}.mo/s/md5sum=.*name=/name=/' \
../package.xml >%{name}.xml
+
%build
cd %{pear_name}-%{version}
@@ -48,17 +67,29 @@ do
msgfmt $po -o $(dirname $po)/$(basename $po .po).mo
done
+
%install
cd %{pear_name}-%{version}
-%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+%if 0%{?fedora} > 13
%find_lang %{pear_name}
+%else
+sh %{SOURCE1} %{buildroot} %{pear_name}
+%endif
+
+
+%check
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+phpunit -d date.timezone=UTC AllTests.php
+
%post
%{__pear} install --nodeps --soft --force --register-only \
@@ -67,22 +98,27 @@ install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
%postun
if [ $1 -eq 0 ] ; then
%{__pear} uninstall --nodeps --ignore-errors --register-only \
- pear.horde.org/%{pear_name} >/dev/null || :
+ %{pear_channel}/%{pear_name} >/dev/null || :
fi
+
%files -f %{pear_name}-%{version}/%{pear_name}.lang
%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Horde/Alarm
%{pear_phpdir}/Horde/Alarm.php
-%{pear_testdir}/Horde_Alarm
+%{pear_testdir}/%{pear_name}
# own locales (non standard) directories, .mo own by find_lang
-%dir %{pear_datadir}/Horde_Alarm
-%dir %{pear_datadir}/Horde_Alarm/locale
-%dir %{pear_datadir}/Horde_Alarm/locale/*
-%dir %{pear_datadir}/Horde_Alarm/locale/*/LC_MESSAGES
-%doc %{pear_datadir}/Horde_Alarm/migration/1_horde_alarms_table.php
+%dir %{pear_datadir}/%{pear_name}
+%dir %{pear_datadir}/%{pear_name}/locale
+%dir %{pear_datadir}/%{pear_name}/locale/*
+%dir %{pear_datadir}/%{pear_name}/locale/*/LC_MESSAGES
+%doc %{pear_datadir}/%{pear_name}/migration
+
%changelog
+* Fri Nov 2 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.0-1
+- Update to 2.0.0 for remi repo
+
* Sat Jan 28 2012 Nick Bebout <nb@fedoraproject.org> - 1.0.7-1
- Initial package