summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-02 06:45:09 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-02 06:45:09 +0100
commit091db93cd1c64364aba60354d710369e98df6280 (patch)
treeccfc79881df7fd4a61d976a9a3b0de7f36bfaefa
php-horde-Horde-Alarm: impot from review
-rw-r--r--php-horde-Horde-Alarm.spec88
1 files changed, 88 insertions, 0 deletions
diff --git a/php-horde-Horde-Alarm.spec b/php-horde-Horde-Alarm.spec
new file mode 100644
index 0000000..039be9b
--- /dev/null
+++ b/php-horde-Horde-Alarm.spec
@@ -0,0 +1,88 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Horde_Alarm
+
+Name: php-horde-Horde-Alarm
+Version: 1.0.7
+Release: 1%{?dist}
+Summary: Horde Alarm Libraries
+
+Group: Development/Libraries
+License: LGPLv2+
+URL: http://pear.horde.org
+Source0: http://pear.horde.org/get/%{pear_name}-%{version}.tgz
+
+BuildArch: noarch
+BuildRequires: php-pear(PEAR) >= 1.7.0
+BuildRequires: gettext
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php-pear(pear.horde.org/Horde_Date) < 2.0.0
+Requires: php-pear(pear.horde.org/Horde_Exception) < 2.0.0
+Requires: php-pear(pear.horde.org/Horde_Translation) < 2.0.0
+Requires: php-pear(PEAR) >= 1.7.0
+Provides: php-pear(pear.horde.org/Horde_Alarm) = %{version}
+BuildRequires: php-channel(pear.horde.org)
+Requires: php-channel(pear.horde.org)
+
+%description
+An interface to deal with reminders, alarms and notifications through a
+standardized API. The following notification methods are currently
+available: standard Horde notifications, pop-ups, emails.
+
+%prep
+%setup -q -c
+cd %{pear_name}-%{version}
+
+# Don't install .po and .pot files
+# Remove checksum for .mo, as we regenerate them
+sed -e '/%{pear_name}.po/d' \
+ -e '/%{pear_name}.mo/s/md5sum=.*name=/name=/' \
+ ../package.xml >%{name}.xml
+
+%build
+cd %{pear_name}-%{version}
+
+# Regenerate the locales
+for po in $(find locale -name \*.po)
+do
+ msgfmt $po -o $(dirname $po)/$(basename $po .po).mo
+done
+
+%install
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+
+# Clean up unnecessary files
+rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+
+# Install XML package description
+mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
+install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+%find_lang %{pear_name}
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ pear.horde.org/%{pear_name} >/dev/null || :
+fi
+
+%files -f %{pear_name}-%{version}/%{pear_name}.lang
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/Alarm
+%{pear_phpdir}/Horde/Alarm.php
+%{pear_testdir}/Horde_Alarm
+# own locales (non standard) directories, .mo own by find_lang
+%dir %{pear_datadir}/Horde_Alarm
+%dir %{pear_datadir}/Horde_Alarm/locale
+%dir %{pear_datadir}/Horde_Alarm/locale/*
+%dir %{pear_datadir}/Horde_Alarm/locale/*/LC_MESSAGES
+%doc %{pear_datadir}/Horde_Alarm/migration/1_horde_alarms_table.php
+
+%changelog
+* Sat Jan 28 2012 Nick Bebout <nb@fedoraproject.org> - 1.0.7-1
+- Initial package