summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-06 16:31:51 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-06 16:31:51 +0200
commitd3b8b294aece4273d9455b8dae6ed75c2a122a50 (patch)
tree530e8f88d8607b8325dfddb7725b7e7d6ddf9f55
php-hoa-math: wip
-rw-r--r--LICENSE29
-rw-r--r--Makefile4
-rw-r--r--php-hoa-math-autoload.php19
-rw-r--r--php-hoa-math.spec125
4 files changed, 177 insertions, 0 deletions
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 0000000..52862ba
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,29 @@
+ New BSD License
+
+
+
+Copyright © 2007-2016, Hoa community.
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ * Neither the name of the Hoa nor the names of its contributors may be
+ used to endorse or promote products derived from this software without
+ specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDERS AND CONTRIBUTORS BE
+LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGE.
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-hoa-math-autoload.php b/php-hoa-math-autoload.php
new file mode 100644
index 0000000..c721ebe
--- /dev/null
+++ b/php-hoa-math-autoload.php
@@ -0,0 +1,19 @@
+<?php
+/* Autoloader for hoa/math and its dependencies */
+
+$vendor = '/usr/share/php';
+
+// Dependencies
+foreach ([
+ $vendor . '/Hoa/Compiler/autoload.php' => true,
+ $vendor . '/Hoa/Consistency/autoload.php' => true,
+ $vendor . '/Hoa/Exception/autoload.php' => true,
+ $vendor . '/Hoa/Iterator/autoload.php' => true,
+ $vendor . '/Hoa/Protocol/autoload.php' => true,
+ $vendor . '/Hoa/Zformat/autoload.php' => true,
+ ] as $dep => $mandatory) {
+ if ($mandatory || file_exists($dep)) require_once($dep);
+}
+
+$fedoraHoaLoader->addNamespace('Hoa\\Math\\', __DIR__, true);
+
diff --git a/php-hoa-math.spec b/php-hoa-math.spec
new file mode 100644
index 0000000..a81598c
--- /dev/null
+++ b/php-hoa-math.spec
@@ -0,0 +1,125 @@
+# remirepo/fedora spec file for php-hoa-math
+#
+# Copyright (c) 2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 1
+%global gh_commit 1997df8aeb2b2f8706cfef3b2c2c665efc2689fa
+#global gh_date 20150728
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner hoaproject
+%global gh_project Math
+%global php_home %{_datadir}/php
+%global ns_vendor Hoa
+%global ns_project Math
+%global pk_vendor hoa
+%global pk_project math
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{pk_vendor}-%{pk_project}
+Version: 1.16.01.29
+%global specrel 0
+Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
+Summary: The %{ns_vendor}\%{ns_project} library.
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source1: %{name}-autoload.php
+Source2: http://hoa-project.net/LICENSE
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+%if %{with_tests}
+BuildRequires: php-composer(%{pk_vendor}/compiler) >= 3.0
+BuildRequires: php-composer(%{pk_vendor}/consistency) >= 1.0
+BuildRequires: php-composer(%{pk_vendor}/exception) >= 1.0
+BuildRequires: php-composer(%{pk_vendor}/iterator) >= 2.0
+BuildRequires: php-composer(%{pk_vendor}/protocol) >= 1.0
+BuildRequires: php-composer(%{pk_vendor}/zformat) >= 1.0
+# from composer.json, "require-dev": {
+# "hoa/test": "~2.0"
+BuildRequires: php-composer(%{pk_vendor}/test) >= 2.0
+%endif
+
+# from composer.json, "require": {
+# "hoa/compiler" : "~3.0",
+# "hoa/consistency": "~1.0",
+# "hoa/exception" : "~1.0",
+# "hoa/iterator" : "~2.0",
+# "hoa/protocol" : "~1.0",
+# "hoa/zformat" : "~1.0"
+Requires: php-composer(%{pk_vendor}/compiler) >= 3.0
+Requires: php-composer(%{pk_vendor}/compiler) < 4
+Requires: php-composer(%{pk_vendor}/consistency) >= 1.0
+Requires: php-composer(%{pk_vendor}/consistency) < 2
+Requires: php-composer(%{pk_vendor}/exception) >= 1.0
+Requires: php-composer(%{pk_vendor}/exception) < 2
+Requires: php-composer(%{pk_vendor}/iterator) >= 2.0
+Requires: php-composer(%{pk_vendor}/iterator) < 3
+Requires: php-composer(%{pk_vendor}/protocol) >= 1.0
+Requires: php-composer(%{pk_vendor}/protocol) < 2
+Requires: php-composer(%{pk_vendor}/zformat) >= 1.0
+Requires: php-composer(%{pk_vendor}/zformat) < 2
+# from phpcompatinfo report for version 1.16.01.29
+Requires: php-spl
+
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+
+
+%description
+The %{ns_vendor}\%{ns_project} library provides tools around
+mathemetical operations.
+
+Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+cp %{SOURCE1} autoload.php
+cp %{SOURCE2} LICENSE
+
+%build
+: Nothing
+
+%install
+rm -rf %{buildroot}
+mkdir -p %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}
+cp -pr *php %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/
+find . -mindepth 1 -maxdepth 1 -type d \! \( -name Test -o -name Documentation \) -print -exec \
+ cp -pr {} %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project} \;
+
+
+%check
+%if %{with_tests}
+%else
+: bootstrap build with test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%doc *md
+%{php_home}/%{ns_vendor}/%{ns_project}
+
+
+%changelog
+* Wed Apr 6 2016 Remi Collet <remi@fedoraproject.org> - 1.16.01.29-0
+- initial package
+- bootstrap build
+