summaryrefslogtreecommitdiffstats
path: root/php-hoa-file.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-06 13:09:29 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-06 13:09:29 +0200
commit3f2e560f38a9e87db8fd037f5118f425bbe1a000 (patch)
tree1cb43d7f16bbcc226808241e0b57a96ad2018523 /php-hoa-file.spec
php-hoa-file: wip
Diffstat (limited to 'php-hoa-file.spec')
-rw-r--r--php-hoa-file.spec125
1 files changed, 125 insertions, 0 deletions
diff --git a/php-hoa-file.spec b/php-hoa-file.spec
new file mode 100644
index 0000000..6891c4b
--- /dev/null
+++ b/php-hoa-file.spec
@@ -0,0 +1,125 @@
+# remirepo/fedora spec file for php-hoa-file
+#
+# Copyright (c) 2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 1
+%global gh_commit bc04ddb476bfeee03c2be585fc37a98d2887277b
+#global gh_date 20150728
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner hoaproject
+%global gh_project File
+%global php_home %{_datadir}/php
+%global ns_vendor Hoa
+%global ns_project File
+%global pk_vendor hoa
+%global pk_project file
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{pk_vendor}-%{pk_project}
+Version: 1.16.01.15
+%global specrel 0
+Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
+Summary: The %{ns_vendor}\%{ns_project} library.
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source1: %{name}-autoload.php
+Source2: http://hoa-project.net/LICENSE
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+%if %{with_tests}
+BuildRequires: php-composer(%{pk_vendor}/consistency) >= 1.0
+BuildRequires: php-composer(%{pk_vendor}/event) >= 1.0
+BuildRequires: php-composer(%{pk_vendor}/exception) >= 1.0
+BuildRequires: php-composer(%{pk_vendor}/stream) >= 1.0
+BuildRequires: php-composer(%{pk_vendor}/iterator) >= 2.0
+# From composer.json, "require-dev": {
+# "hoa/test": "~2.0"
+BuildRequires: php-composer(%{pk_vendor}/test) >= 2.0
+%endif
+
+# from composer.json, "require": {
+# "hoa/consistency": "~1.0",
+# "hoa/event" : "~1.0",
+# "hoa/exception" : "~1.0",
+# "hoa/stream" : "~1.0",
+# "hoa/iterator" : "~2.0"
+Requires: php-composer(%{pk_vendor}/consistency) >= 1.0
+Requires: php-composer(%{pk_vendor}/consistency) < 2
+Requires: php-composer(%{pk_vendor}/event) >= 1.0
+Requires: php-composer(%{pk_vendor}/event) < 2
+Requires: php-composer(%{pk_vendor}/exception) >= 1.0
+Requires: php-composer(%{pk_vendor}/exception) < 2
+Requires: php-composer(%{pk_vendor}/stream) >= 1.0
+Requires: php-composer(%{pk_vendor}/stream) < 2
+Requires: php-composer(%{pk_vendor}/iterator) >= 2.0
+Requires: php-composer(%{pk_vendor}/iterator) < 3
+# from phpcompatinfo report for version 1.16.01.15
+Requires: php-ctype
+Requires: php-date
+Requires: php-intl
+Requires: php-mbstring
+Requires: php-pcre
+Requires: php-spl
+
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+
+
+%description
+The %{ns_vendor}\%{ns_project} library.
+
+Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+cp %{SOURCE1} autoload.php
+cp %{SOURCE2} LICENSE
+
+%build
+: Nothing
+
+%install
+rm -rf %{buildroot}
+mkdir -p %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}
+cp -pr *php %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/
+find . -mindepth 1 -maxdepth 1 -type d \! -name Test -print -exec \
+ cp -pr {} %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project} \; \
+
+
+%check
+%if %{with_tests}
+%else
+: bootstrap build with test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%doc *md
+%{php_home}/%{ns_vendor}/%{ns_project}
+
+
+%changelog
+* Wed Apr 6 2016 Remi Collet <remi@fedoraproject.org> - 1.16.01.15-0
+- initial package
+- bootstrap build
+