summaryrefslogtreecommitdiffstats
path: root/php-guzzlehttp-guzzle6.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-guzzlehttp-guzzle6.spec')
-rw-r--r--php-guzzlehttp-guzzle6.spec14
1 files changed, 9 insertions, 5 deletions
diff --git a/php-guzzlehttp-guzzle6.spec b/php-guzzlehttp-guzzle6.spec
index cfa9b67..d000d19 100644
--- a/php-guzzlehttp-guzzle6.spec
+++ b/php-guzzlehttp-guzzle6.spec
@@ -12,8 +12,8 @@
%global github_owner guzzle
%global github_name guzzle
-%global github_version 6.5.7
-%global github_commit 724562fa861e21a4071c652c8a159934e4f05592
+%global github_version 6.5.8
+%global github_commit a52f0440530b54fa079ce76e8c5d196a42cad981
%global composer_vendor guzzlehttp
%global composer_project guzzle
@@ -23,8 +23,8 @@
# "guzzlehttp/promises": "^1.0"
%global promises_min_ver 1.0
%global promises_max_ver 2.0
-# "guzzlehttp/psr7": "^1.6.1"
-%global psr7_min_ver 1.6.1
+# "guzzlehttp/psr7": "^1.9"
+%global psr7_min_ver 1.9
%global psr7_max_ver 2.0
# "psr/log": "^1.1"
%global psr_log_min_ver 1.1
@@ -195,7 +195,7 @@ AUTOLOAD
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit7)
-for PHP_EXEC in php php74 php80 php81; do
+for PHP_EXEC in php php74 php80 php81 php82; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
VER=$($PHP_EXEC -r 'echo PHP_VERSION_ID;')
@@ -225,6 +225,10 @@ exit $RETURN_CODE
%changelog
+* Wed Jun 22 2022 Remi Collet <remi@remirepo.net> - 6.5.8-1
+- update to 6.5.8
+- raise dependency on guzzlehttp/psr7 1.9
+
* Mon Jun 13 2022 Remi Collet <remi@remirepo.net> - 6.5.7-1
- update to 6.5.7