summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-guzzle-Guzzle.spec9
1 files changed, 8 insertions, 1 deletions
diff --git a/php-guzzle-Guzzle.spec b/php-guzzle-Guzzle.spec
index c415aca..01ee00f 100644
--- a/php-guzzle-Guzzle.spec
+++ b/php-guzzle-Guzzle.spec
@@ -60,7 +60,7 @@
Name: php-guzzle-%{pear_name}
Version: %{github_version}
-Release: 5%{?dist}
+Release: 7%{?dist}
Summary: PHP HTTP client library and framework for building RESTful web service clients
Group: Development/Libraries
@@ -274,6 +274,10 @@ sed "s#require.*autoload.*#require __DIR__ . '/autoload.php';#" \
-i tests/bootstrap.php
: Skip tests known to fail
+sed 's/function testPurgeRemovesAllMethodCaches/function SKIP_testPurgeRemovesAllMethodCaches/' \
+ -i tests/Guzzle/Tests/Plugin/Cache/DefaultCacheStorageTest.php
+sed 's/function testAddsBody/function SKIP_testAddsBody/' \
+ -i tests/Guzzle/Tests/Stream/PhpStreamRequestFactoryTest.php
%if 0%{?rhel} == 6 || 0%{?rhel} == 5
rm -f tests/Guzzle/Tests/Http/RedirectPluginTest.php
sed 's/function testCanCreateStreamsUsingDefaultFactory/function SKIP_testCanCreateStreamsUsingDefaultFactory/' \
@@ -331,6 +335,9 @@ fi
%exclude %{phpdir}/Guzzle/*/*/composer.json
%changelog
+* Sun Feb 28 2016 Shawn Iwinski <shawn.iwinski@gmail.com> - 3.9.3-7
+- Skip additional tests known to fail (RHBZ #1307858)
+
* Thu Aug 13 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 3.9.3-5
- Added explicit autoloader build dependency
- Minor cleanups