summaryrefslogtreecommitdiffstats
path: root/php-felixfbecker-advanced-json-rpc3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-felixfbecker-advanced-json-rpc3.spec')
-rw-r--r--php-felixfbecker-advanced-json-rpc3.spec7
1 files changed, 3 insertions, 4 deletions
diff --git a/php-felixfbecker-advanced-json-rpc3.spec b/php-felixfbecker-advanced-json-rpc3.spec
index a6d4dca..abfe0fd 100644
--- a/php-felixfbecker-advanced-json-rpc3.spec
+++ b/php-felixfbecker-advanced-json-rpc3.spec
@@ -25,7 +25,6 @@ Version: 3.0.1
Release: 2%{?dist}
Summary: A more advanced JSONRPC implementation
-Group: Development/Libraries
License: ISC
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
@@ -36,7 +35,7 @@ BuildArch: noarch
BuildRequires: php(language) >= 7.0
BuildRequires: php-reflection
BuildRequires: php-json
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(netresearch/jsonmapper) >= 1.0 with php-composer(netresearch/jsonmapper) < 2)
BuildRequires: (php-composer(phpdocumentor/reflection-docblock) >= 4.0 with php-composer(phpdocumentor/reflection-docblock) < 5)
%else
@@ -55,7 +54,7 @@ BuildRequires: php-composer(fedora/autoloader)
# "netresearch/jsonmapper": "^1.0",
# "phpdocumentor/reflection-docblock": "^3.1"
Requires: php(language) >= 7.0
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(netresearch/jsonmapper) >= 1.0 with php-composer(netresearch/jsonmapper) < 2)
Requires: (php-composer(phpdocumentor/reflection-docblock) >= 4.0 with php-composer(phpdocumentor/reflection-docblock) < 5)
%else
@@ -123,7 +122,7 @@ require '%{buildroot}%{php_home}/%{ns_project}%{major}/autoload.php';
EOF
ret=0
-for cmd in php php70 php71 php72; do
+for cmd in php php70 php71 php72 php73; do
if which $cmd; then
$cmd %{_bindir}/phpunit6 --bootstrap bootstrap.php --verbose tests || ret=1
fi