summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json6
-rw-r--r--php-felixfbecker-advanced-json-rpc3.spec34
2 files changed, 23 insertions, 17 deletions
diff --git a/composer.json b/composer.json
index a7e1d7b..1c154df 100644
--- a/composer.json
+++ b/composer.json
@@ -20,12 +20,12 @@
}
},
"require": {
- "php": ">=7.0",
+ "php": "^7.1 || ^8.0",
"netresearch/jsonmapper": "^1.0 || ^2.0",
- "phpdocumentor/reflection-docblock": "^4.0.0 || ^5.0.0"
+ "phpdocumentor/reflection-docblock": "^4.3.4 || ^5.0.0"
},
"require-dev": {
- "phpunit/phpunit": "^6.0.0"
+ "phpunit/phpunit": "^7.0 || ^8.0"
},
"minimum-stability": "dev",
"prefer-stable": true
diff --git a/php-felixfbecker-advanced-json-rpc3.spec b/php-felixfbecker-advanced-json-rpc3.spec
index 5addfad..a525719 100644
--- a/php-felixfbecker-advanced-json-rpc3.spec
+++ b/php-felixfbecker-advanced-json-rpc3.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 0ed363f8de17d284d479ec813c9ad3f6834b5c40
+%global gh_commit 06f0b06043c7438959dbdeed8bb3f699a19be22e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner felixfbecker
%global gh_project php-advanced-json-rpc
@@ -21,8 +21,8 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.1.1
-Release: 3%{?dist}
+Version: 3.2.0
+Release: 1%{?dist}
Summary: A more advanced JSONRPC implementation
License: ISC
@@ -34,31 +34,31 @@ Source1: makesrc.sh
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php(language) >= 7.0
+BuildRequires: php(language) >= 7.1
BuildRequires: php-reflection
BuildRequires: php-json
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(netresearch/jsonmapper) >= 1.0 with php-composer(netresearch/jsonmapper) < 4)
-BuildRequires: (php-composer(phpdocumentor/reflection-docblock) >= 4.0 with php-composer(phpdocumentor/reflection-docblock) < 6)
+BuildRequires: (php-composer(netresearch/jsonmapper) >= 1.0 with php-composer(netresearch/jsonmapper) < 4)
+BuildRequires: (php-composer(phpdocumentor/reflection-docblock) >= 4.3.4 with php-composer(phpdocumentor/reflection-docblock) < 6)
%else
BuildRequires: php-netresearch-jsonmapper
BuildRequires: php-phpdocumentor-reflection-docblock4
%endif
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^6.0.0"
-BuildRequires: phpunit6
+# "phpunit/phpunit": "^7.0 || ^8.0""
+BuildRequires: phpunit8
# Required by autoloader
BuildRequires: php-composer(fedora/autoloader)
%endif
# From composer.json, "require": {
-# "php": ">=7.0",
+# "php": "^7.1 || ^8.0",
# "netresearch/jsonmapper": "^1.0 || ^2.0",
-# "phpdocumentor/reflection-docblock": "^4.0.0 || ^5.0.0"
-Requires: php(language) >= 7.0
+# "phpdocumentor/reflection-docblock": "^4.3.4 || ^5.0.0"
+Requires: php(language) >= 7.1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(netresearch/jsonmapper) >= 1.0 with php-composer(netresearch/jsonmapper) < 4)
-Requires: (php-composer(phpdocumentor/reflection-docblock) >= 4.0 with php-composer(phpdocumentor/reflection-docblock) < 6)
+Requires: (php-composer(netresearch/jsonmapper) >= 1.0 with php-composer(netresearch/jsonmapper) < 4)
+Requires: (php-composer(phpdocumentor/reflection-docblock) >= 4.3.4 with php-composer(phpdocumentor/reflection-docblock) < 6)
%else
Requires: php-netresearch-jsonmapper
Requires: php-phpdocumentor-reflection-docblock4
@@ -129,7 +129,7 @@ EOF
ret=0
for cmd in php php72 php73 php74 php80; do
if which $cmd; then
- $cmd %{_bindir}/phpunit6 --bootstrap bootstrap.php --verbose tests || ret=1
+ $cmd %{_bindir}/phpunit8 --bootstrap bootstrap.php --verbose tests || ret=1
fi
done
exit $ret
@@ -147,6 +147,12 @@ exit $ret
%changelog
+* Mon Jan 11 2021 Remi Collet <remi@remirepo.net> - 3.2.0-1
+- update to 3.2.0 (no change)
+- raise dependency on PHP 7.1
+- raise dependency on phpdocumentor/reflection-docblock 4.3.4
+- switch to phpunit8
+
* Tue Aug 11 2020 Remi Collet <remi@remirepo.net> - 3.1.1-3
- allow netresearch/jsonmapper 3.0