summaryrefslogtreecommitdiffstats
path: root/php-doctrine-orm.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-doctrine-orm.spec')
-rw-r--r--php-doctrine-orm.spec41
1 files changed, 34 insertions, 7 deletions
diff --git a/php-doctrine-orm.spec b/php-doctrine-orm.spec
index 1155934..e5b174b 100644
--- a/php-doctrine-orm.spec
+++ b/php-doctrine-orm.spec
@@ -13,8 +13,8 @@
%global github_owner doctrine
%global github_name doctrine2
-%global github_version 2.5.12
-%global github_commit 984535cadc609e9eef8c89414aa3568ee97aa79f
+%global github_version 2.5.14
+%global github_commit 810a7baf81462a5ddf10e8baa8cb94b6eec02754
%global composer_vendor doctrine
%global composer_project orm
@@ -52,7 +52,7 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 2%{?dist}
+Release: 1%{?dist}
Summary: Doctrine Object-Relational-Mapper (ORM)
Group: Development/Libraries
@@ -68,13 +68,22 @@ Source1: %{name}-get-source.sh
# 2) Auto-load using Doctrine\Common\ClassLoader
Patch0: %{name}-bin.patch
-Patch1: %{name}-php72.patch
+Patch1: %{name}-php73.patch
BuildArch: noarch
# Tests
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(doctrine/cache) >= %{cache_min_ver} with php-composer(doctrine/cache) < %{cache_max_ver})
+BuildRequires: (php-composer(doctrine/collections) >= %{collections_min_ver} with php-composer(doctrine/collections) < %{collections_max_ver})
+BuildRequires: (php-composer(doctrine/common) >= %{common_min_ver} with php-composer(doctrine/common) < %{common_max_ver})
+BuildRequires: (php-composer(doctrine/dbal) >= %{dbal_min_ver} with php-composer(doctrine/dbal) < %{dbal_max_ver})
+BuildRequires: (php-composer(doctrine/instantiator) >= %{instantiator_min_ver} with php-composer(doctrine/instantiator) < %{instantiator_max_ver})
+BuildRequires: (php-composer(symfony/console) >= %{symfony_min_ver} with php-composer(symfony/console) < %{symfony_max_ver})
+BuildRequires: (php-composer(symfony/yaml) >= %{symfony_min_ver} with php-composer(symfony/yaml) < %{symfony_max_ver})
+%else
BuildRequires: php-composer(doctrine/cache) < %{cache_max_ver}
BuildRequires: php-composer(doctrine/cache) >= %{cache_min_ver}
BuildRequires: php-composer(doctrine/collections) < %{collections_max_ver}
@@ -90,6 +99,8 @@ BuildRequires: php-composer(symfony/console) < %{symfony_max_ver}
BuildRequires: php-composer(symfony/console) >= %{symfony_min_ver}
BuildRequires: php-composer(symfony/yaml) < %{symfony_max_ver}
BuildRequires: php-composer(symfony/yaml) >= %{symfony_min_ver}
+%endif
+BuildRequires: php-composer(phpunit/phpunit)
BuildRequires: php-pdo
# phpcompatinfo (computed from version 2.5.11)
BuildRequires: php-ctype
@@ -107,6 +118,16 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(doctrine/cache) >= %{cache_min_ver} with php-composer(doctrine/cache) < %{cache_max_ver})
+Requires: (php-composer(doctrine/collections) >= %{collections_min_ver} with php-composer(doctrine/collections) < %{collections_max_ver})
+Requires: (php-composer(doctrine/common) >= %{common_min_ver} with php-composer(doctrine/common) < %{common_max_ver})
+Requires: (php-composer(doctrine/dbal) >= %{dbal_min_ver} with php-composer(doctrine/dbal) < %{dbal_max_ver})
+Requires: (php-composer(doctrine/instantiator) >= %{instantiator_min_ver} with php-composer(doctrine/instantiator) < %{instantiator_max_ver})
+Requires: (php-composer(symfony/console) >= %{symfony_min_ver} with php-composer(symfony/console) < %{symfony_max_ver})
+# composer.json: suggest
+Requires: (php-composer(symfony/yaml) >= %{symfony_min_ver} with php-composer(symfony/yaml) < %{symfony_max_ver})
+%else
Requires: php-composer(doctrine/cache) < %{cache_max_ver}
Requires: php-composer(doctrine/cache) >= %{cache_min_ver}
Requires: php-composer(doctrine/collections) < %{collections_max_ver}
@@ -119,10 +140,10 @@ Requires: php-composer(doctrine/instantiator) < %{instantiator_max_ver}
Requires: php-composer(doctrine/instantiator) >= %{instantiator_min_ver}
Requires: php-composer(symfony/console) < %{symfony_max_ver}
Requires: php-composer(symfony/console) >= %{symfony_min_ver}
-Requires: php-pdo
-# composer.json: suggest
Requires: php-composer(symfony/yaml) < %{symfony_max_ver}
Requires: php-composer(symfony/yaml) >= %{symfony_min_ver}
+%endif
+Requires: php-pdo
# phpcompatinfo (computed from version 2.5.11)
Requires: php-ctype
Requires: php-date
@@ -261,7 +282,7 @@ rm tests/Doctrine/Tests/ORM/Functional/Ticket/GH6464Test.php
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" %{?rhel:php55} php56 php70 php71 php72; do
+for PHP_EXEC in "" %{?rhel:php55 php56} php70 php71 php72 php73; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose -d memory_limit="512M" --bootstrap bootstrap.php \
|| RETURN_CODE=1
@@ -282,6 +303,12 @@ exit $RETURN_CODE
%changelog
+* Tue Oct 16 2018 Remi Collet <remi@remirepo.net> - 2.5.14-1
+- update to 2.5.14
+- fix FTBFS from Koschei add patch for PHP 7.3 from
+ https://github.com/doctrine/doctrine2/pull/7431
+- use range dependencies
+
* Fri Nov 10 2017 Remi Collet <remi@remirepo.net> - 2.5.12-2
- fix more tests failing since 7.1