summaryrefslogtreecommitdiffstats
path: root/php-doctrine-orm.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-doctrine-orm.spec')
-rw-r--r--php-doctrine-orm.spec16
1 files changed, 10 insertions, 6 deletions
diff --git a/php-doctrine-orm.spec b/php-doctrine-orm.spec
index 9836e88..4a114cf 100644
--- a/php-doctrine-orm.spec
+++ b/php-doctrine-orm.spec
@@ -12,9 +12,9 @@
#
%global github_owner doctrine
-%global github_name doctrine2
-%global github_version 2.6.3
-%global github_commit 434820973cadf2da2d66e7184be370084cc32ca8
+%global github_name orm
+%global github_version 2.6.4
+%global github_commit b52ef5a1002f99ab506a5a2d6dba5a2c236c5f43
%global composer_vendor doctrine
%global composer_project orm
@@ -101,7 +101,7 @@ BuildRequires: php-composer(symfony/console) >= %{symfony_min_ver}
BuildRequires: php-composer(symfony/yaml) < %{symfony_max_ver}
BuildRequires: php-composer(symfony/yaml) >= %{symfony_min_ver}
%endif
-BuildRequires: phpunit6 >= 6.5
+BuildRequires: phpunit7 >= 7.5
BuildRequires: php-pdo
# phpcompatinfo (computed from version 2.5.11)
BuildRequires: php-ctype
@@ -266,9 +266,9 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in "" php71 php72 php73; do
+for PHP_EXEC in "" php71 php72 php73 php74; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC %{_bindir}/phpunit6 --verbose -d memory_limit="512M" --bootstrap bootstrap.php \
+ $PHP_EXEC %{_bindir}/phpunit7 --verbose -d memory_limit="512M" --bootstrap bootstrap.php \
|| RETURN_CODE=1
fi
done
@@ -288,6 +288,10 @@ exit $RETURN_CODE
%changelog
+* Mon Sep 30 2019 Remi Collet <remi@remirepo.net> - 2.6.4-1
+- update to 2.6.4
+- switch to phpunit7
+
* Thu Nov 22 2018 Remi Collet <remi@remirepo.net> - 2.6.3-1
- update to 2.6.3