summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json18
-rw-r--r--php-doctrine-orm.spec24
2 files changed, 24 insertions, 18 deletions
diff --git a/composer.json b/composer.json
index b316690..67afdcd 100644
--- a/composer.json
+++ b/composer.json
@@ -16,30 +16,32 @@
"sort-packages": true
},
"require": {
- "php": "^7.1|^8.0",
+ "php": "^7.1 ||^8.0",
+ "ext-ctype": "*",
"ext-pdo": "*",
"composer/package-versions-deprecated": "^1.8",
"doctrine/annotations": "^1.13",
- "doctrine/cache": "^1.11.3|^2.0.3",
+ "doctrine/cache": "^1.12.1 || ^2.1.1",
"doctrine/collections": "^1.5",
"doctrine/common": "^3.0.3",
"doctrine/dbal": "^2.13.0",
"doctrine/deprecations": "^0.5.3",
"doctrine/event-manager": "^1.1",
- "doctrine/inflector": "^1.4|^2.0",
+ "doctrine/inflector": "^1.4 || ^2.0",
"doctrine/instantiator": "^1.3",
"doctrine/lexer": "^1.0",
"doctrine/persistence": "^2.2",
"psr/cache": "^1 || ^2 || ^3",
- "symfony/console": "^3.0|^4.0|^5.0|^6.0"
+ "symfony/console": "^3.0 || ^4.0 || ^5.0 || ^6.0"
},
"require-dev": {
"doctrine/coding-standard": "^9.0",
- "phpstan/phpstan": "^0.12.83",
- "phpunit/phpunit": "^7.5|^8.5|^9.4",
+ "phpbench/phpbench": "^0.16.10 || ^1.0",
+ "phpstan/phpstan": "0.12.94",
+ "phpunit/phpunit": "^7.5 || ^8.5 || ^9.4",
"squizlabs/php_codesniffer": "3.6.0",
- "symfony/cache": "^4.4|^5.2",
- "symfony/yaml": "^3.4|^4.0|^5.0|^6.0",
+ "symfony/cache": "^4.4 || ^5.2",
+ "symfony/yaml": "^3.4 || ^4.0 || ^5.0 || ^6.0",
"vimeo/psalm": "4.7.0"
},
"suggest": {
diff --git a/php-doctrine-orm.spec b/php-doctrine-orm.spec
index 3cfa478..dea1a81 100644
--- a/php-doctrine-orm.spec
+++ b/php-doctrine-orm.spec
@@ -13,19 +13,19 @@
%global github_owner doctrine
%global github_name orm
-%global github_version 2.9.3
-%global github_commit 82e77cf5089a1303733f75f0f0ed01be3ab9ec22
+%global github_version 2.9.4
+%global github_commit b19a13f4edfaa5806109cd899f5912a7df1547b5
%global composer_vendor doctrine
%global composer_project orm
-# "php": "^7.1|^8.0"
+# "php": "^7.1 || ^8.0"
%global php_min_ver 7.1
# "doctrine/annotations": "^1.13",
%global annotations_min_ver 1.13
%global annotations_max_ver 2
-# "doctrine/cache": "^1.11.3|^2.0.3"
-%global cache_min_ver 1.11.3
+# "doctrine/cache": "^1.12.1 || ^2.1.1"
+%global cache_min_ver 1.12.1
%global cache_max_ver 3
# "doctrine/collections": "^1.5"
%global collections_min_ver 1.5
@@ -39,7 +39,7 @@
# "doctrine/deprecations": "^0.5.3"
%global deprecations_min_ver 0.5.3
%global deprecations_max_ver 1
-# "doctrine/inflector": "^1.4|^2.0"
+# "doctrine/inflector": "^1.4 || ^2.0"
%global inflector_min_ver 1.4
%global inflector_max_ver 3
# "doctrine/instantiator": "^1.3"
@@ -54,11 +54,11 @@
# "doctrine/event-manager": "^1.1"
%global event_min_ver 1.1
%global event_max_ver 2
-# "symfony/console": "^3.0|^4.0|^5.0|^6.0"
-# "symfony/yaml": "~^3.4|^4.0|^5.0|^6.0"
+# "symfony/console": "^3.0 || ^4.0 || ^5.0 || ^6.0"
+# "symfony/yaml": "^3.4 || ^4.0 || ^5.0 || ^6.0"
%global symfony_min_ver 3.4
%global symfony_max_ver 7
-# "symfony/cache": "^4.4|^5.2",
+# "symfony/cache": "^4.4 || ^5.2",
%global sym_cache_min_ver 4.4
%global sym_cache_max_ver 6
# "psr/cache": "^1 || ^2 || ^3",
@@ -72,7 +72,7 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 2%{?dist}
+Release: 1%{?dist}
Summary: Doctrine Object-Relational-Mapper (ORM)
License: MIT
@@ -388,6 +388,10 @@ exit $RETURN_CODE
%changelog
+* Thu Aug 12 2021 Remi Collet <remi@remirepo.net> - 2.9.4-1
+- update to 2.9.4
+- raise dependency on doctrine/cache 1.12.1
+
* Fri Jul 30 2021 Remi Collet <remi@remirepo.net> - 2.9.3-2
- skip 1 test, fix FTBFS #1987811