summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json4
-rw-r--r--php-doctrine-orm.spec9
2 files changed, 8 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index cf7b249..e6525f3 100644
--- a/composer.json
+++ b/composer.json
@@ -42,13 +42,13 @@
"doctrine/annotations": "^1.13",
"doctrine/coding-standard": "^9.0.2 || ^10.0",
"phpbench/phpbench": "^0.16.10 || ^1.0",
- "phpstan/phpstan": "~1.4.10 || 1.8.5",
+ "phpstan/phpstan": "~1.4.10 || 1.9.2",
"phpunit/phpunit": "^7.5 || ^8.5 || ^9.5",
"psr/log": "^1 || ^2 || ^3",
"squizlabs/php_codesniffer": "3.7.1",
"symfony/cache": "^4.4 || ^5.4 || ^6.0",
"symfony/yaml": "^3.4 || ^4.0 || ^5.0 || ^6.0",
- "vimeo/psalm": "4.27.0"
+ "vimeo/psalm": "4.30.0"
},
"conflict": {
"doctrine/annotations": "<1.13 || >= 2.0"
diff --git a/php-doctrine-orm.spec b/php-doctrine-orm.spec
index 6295be9..63665d1 100644
--- a/php-doctrine-orm.spec
+++ b/php-doctrine-orm.spec
@@ -13,8 +13,8 @@
%global github_owner doctrine
%global github_name orm
-%global github_version 2.13.3
-%global github_commit e750360bd52b080c4cbaaee1b48b80f7dc873b36
+%global github_version 2.13.4
+%global github_commit a5a6cc6630ce497290396d5f206887227820a634
%global composer_vendor doctrine
%global composer_project orm
@@ -393,7 +393,7 @@ rm tests/Doctrine/Tests/ORM/Functional/Ticket/DDC742Test.php
: Upstream tests
RETURN_CODE=0
-for CMDARG in "php %{phpunit}" php74 php80 php81 php82; do
+for CMDARG in "php %{phpunit}" php80 php81 php82; do
if which $CMDARG; then
set $CMDARG
$1 ${2:-%{_bindir}/phpunit9} \
@@ -420,6 +420,9 @@ exit $RETURN_CODE
%changelog
+* Thu Nov 24 2022 Remi Collet <remi@remirepo.net> - 2.13.4-1
+- update to 2.13.4
+
* Fri Oct 7 2022 Remi Collet <remi@remirepo.net> - 2.13.3-1
- update to 2.13.3