summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-22 15:05:44 +0100
committerRemi Collet <remi@remirepo.net>2020-01-22 15:05:44 +0100
commit62d03391e52edd92cfe7c29d0046b0e6c5987d8c (patch)
tree6c1bf1213312fa9ccf61ab99908808f1027f8b0c
parentb2a95ff98313b7fa61aea79187940dfdcbcb10b4 (diff)
skip tests failing with old sqlitev2.6
-rw-r--r--php-doctrine-orm.spec6
1 files changed, 5 insertions, 1 deletions
diff --git a/php-doctrine-orm.spec b/php-doctrine-orm.spec
index 326f0c0..0c16371 100644
--- a/php-doctrine-orm.spec
+++ b/php-doctrine-orm.spec
@@ -267,7 +267,11 @@ BOOTSTRAP
RETURN_CODE=0
for PHP_EXEC in "" php71 php72 php73 php74; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC %{_bindir}/phpunit7 --verbose -d memory_limit="512M" --bootstrap bootstrap.php \
+ $PHP_EXEC %{_bindir}/phpunit7 \
+%if 0%{?rhel} ==6
+ --filter '^((?!(testIssue|testValidateXmlSchema|testDetachedEntityThrowsExceptionOnFlush)).)*$' \
+%endif
+ --verbose -d memory_limit="512M" --bootstrap bootstrap.php \
|| RETURN_CODE=1
fi
done